[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#989987: installation-report Bullseye rc2

Hash: SHA512

Hello Cyril,

you are welcome.

On Thu, 17 Jun 2021 15:23:02 +0200
Cyril Brulebois <kibi@debian.org> wrote:

> Hallo Oliver,
> And thanks for your report.
> Oliver Psotta <oliver.psotta@posteo.de> (2021-06-17):
> > [O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it
> > 
> > Initial boot:           [O ]
> > Detect network card:    [E ]
> > Configure network:      [O ]
> > Detect media:           [E ]
> > Load installer modules: [E ]
> > Clock/timezone setup:   [O ]
> > User/password setup:    [O ]
> > Detect hard drives:     [O ]
> > Partition hard drives:  [O ]
> > Install base system:    [O ]
> > Install tasks:          [O ]
> > Install boot loader:    [O ]
> > Overall install:        [O ]
> > 
> > Comments/Problems: Graphical Install did not find ethernet, because
> > laptop is not equipped with it. But it did not try to search for
> > wireless. Instead I was able to choose my wireless Realtek chip in
> > ethernet window.  
> I do have some laptops around that I'm testing firmware-related issues
> with, and I think I've noticed this (to be confirmed):
>  - on a laptop without wired Ethernet, I'm getting a prompt for the
>    wireless card and its firmware.
>  - when booting it with a USB→Ethernet adapter, I'm getting a prompt
> for the (possibly missing but actually unimportant) firmware for the
>    USB→Ethernet adapter, but no mention of the wireless card or
> missing firmware.

If you want I can send you a screenshot of the Ethernet screen, where I
can select WIFI drivers.
When I plugged in the USB-Ethernet adapter, I will not be asked
anything. Installation then automatically configures network, IP, time
and so on.
> > It could not activate the supplied driver from 2nd USB drive.
> > Mounting of 2nd USB drive was unreliable. Installation worked well
> > after using USB-Ethernet adapter.  
> OK, that part I'm not familiar with, and I cannot really comment.
> You could have used one of the unofficial/non-free images that come
> with all firmware packages:
>   https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/
Good to know, thank you. I will use it for the next installation.

> > Installation process of install via ethernet worked well. Gnome
> > desktop not useable on built in screen because resolution and
> > brightness not changeable, no sound, no BT.  
> Alright, I'm currently chasing that kind of issues. You can double
> check you're using a software-based rendering by installing the
> mesa-utils package, running `glxinfo | grep renderer` should give you
> llvmpipe.
> Wild guess, you're lacking:
>  - firmware-iwlwifi for bluetooth support (I do have a realtek
> wireless card here, but the kernel complains about files that are
> shipped in that package instead).
>  - firmware-amd-graphics for proper display support.
>  - firmware-sof-signed for sound support.
> All those wouldn't have been solved by using the firmware-enabled
> images because we're currently lacking some detection, but I'm
> working on this.
> For users of official installation images (main-only), I'm wondering
> whether to advertise something like this in the installation guide:
>     sudo apt install isenkram-cli
>     sudo isenkram-autoinstall-firmware
>     sudo reboot
> Please note that due to #989884, one should install isenkram-cli from
> unstable to make sure the firmware file to firmware package lookup
> works.
> More on such issues on #989863 and follow-up bug reports when I get a
> chance to sum up my findings.
The situation right now is:
- - Screen resolution, brightness controls and sound are working.
  Probably because of the AMD firmware I've installed. Also the laptop
  is not getting warm anymore.
- - BT is working with the non-free Realtek firmware. WiFi chip cannot be
  activated because of the known bug: "rtw88 / rtl_8821ce: rfe 2 is not
supported". This bug is fixed on Ubuntu, but the range of WiFi is only
2 meters (also known). On Ubuntu there's a proprietary driver for this
which works well. I'm not sure if it is possible to install that on
- - Suspend is not working, also known bug. I was reading somewhere that
  will be fixed in the next main linux kernel.
- - Now my renderer is GLX_MESA_query_renderer and for OpenGL it's AMD
> Tschüss,


Reply to: