[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#987968: flash-kernel: Tinkered a new DTB to make my version of Olimex A64-Olinuxino-eMMC boot

Package: flash-kernel
Version: 3.104
Severity: wishlist

Dear Maintainer,

I could not install a Debian Bullseye that was able to boot on my Olimex A64-Olinuxino-eMMC -A64-OLinuXino-1Ge16GW version - with the nightly built SD card images. Nothing was happening after the message "Starting kernel".

So I followed the mitigation process proposed here: https://wiki.debian.org/InstallingDebianOn/Allwinner#Installing_on_systems_that_are_not_supported_out_of_the_box

As the nightly built DTB was giving the same result - nothing after 'starting kernel', I compiled a DTB from the DTS found in the device tree git repo. It dit not work better.

While I was trying to have a bootable system from the nightly built SD card images, I had noticed that a system install with  Olimex Teres images was nearly woking: it was able to boot, but hanged 30 seconds after the boot.

So I have used the Olimex Teres DTS. I have removed the parts relating to hardware not present on a64-Olinuxino-eMMc. The system can boot. It complains about vcc-p* not found. When I tried to add the parts related to vcc-p* from the a64-Olinuxino-eMMc DTS, the system could not boot anymore (again, nothing after 'Starting kernel').

-- System Information:
Debian Release: bullseye/sid
  APT prefers testing-security
  APT policy: (500, 'testing-security'), (500, 'testing')
Architecture: arm64 (aarch64)

Kernel: Linux 5.10.0-6-arm64 (SMP w/4 CPU threads)
Kernel taint flags: TAINT_CRAP
Locale: LANG=C, LC_CTYPE=C.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages flash-kernel depends on:
ii  debconf [debconf-2.0]  1.5.75
ii  devio                  1.2-1.2+b1
ii  initramfs-tools        0.140
ii  linux-base             4.6
ii  mtd-utils              1:2.1.2-2
ii  ucf                    3.0043

Versions of packages flash-kernel recommends:
ii  u-boot-tools  2021.01+dfsg-4

flash-kernel suggests no packages.

-- Configuration Files:
/etc/flash-kernel/db changed:
Machine: Olimex A64-Olinuxino-eMMC
Kernel-Flavors: arm64
DTB-Id: allwinner/sun50i-a64-olinuxino-emmc.dtb
Boot-Script-Path: /boot/boot.scr
U-Boot-Script-Name: bootscr.uboot-generic
Required-Packages: u-boot-tools

-- debconf information:
* flash-kernel/linux_cmdline: quiet

Reply to: