[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#980205: #980205 installation missing "non free" drivers.

At 05:40 AM 1/18/2021, Holger Wansing wrote:

>Dave Dyer <ddyer@real-me.net> wrote (16 Jan 2021 04:09:02 UTC):
>> Installing on an old x86 cpu which requires "non free" drivers, the
>> installer correctly quotes the needed driver's name.  Bravo. but...
>> 1) it suggests adding removable media, which is basically impossible
>> in the context of the installer running from a memory stick
>Why? You can simply plug in a second USB stick to the PC.

My old device had only 1 usable usb port, and plug/replug didn't
work.  I eventually did try doing the installation with a usb
hub.   I don't think that worked either, because the message
still referred to the .bin file.   AFAIK nothing worked except
installing the driver in the .img 

>> 2) it doesn't tell you in what path on the media to place the driver.
>> I still don't know what path would be appropriate if I could figure out how
>> and where to mount an additional memory stick where it would be seen,
>> but if (instead) I go back and insert the file on the installer stick
>> memory stick, it apparently has to go in /firmware
>That's documented in the installation-guide, see

In the cellar, past the sign that says "beware of the leopard"

You could at least put that link into the message that
included the name of the driver.

>> 3) in my particular case, the driver is brcm/brcmfmac43340-sdio.bin, which
>> *also* requires a text file, brcm/brcmfmac43340-sdio.txt.  I know this because
>> I figured out case 2B and got the installer to accept the .bin; it then
>> it mentions the need for the .txt file.  (Again, thanks, it would have
>> been impossible to proceed without this key information).  However,
>> there's apparently no way to get the installer to accept the .txt
>> file in the same way that it finds the .bin.
>Hmm, looking into the package firmware-brcm80211
>there is no such txt file there.
>So I wonder where you found such file?

Github + Google.  And the file I found works.

>> 4) a workaround, if you can complete the installation without
>> the network working, is to copy both files into /lib/firmware/ and
>> magically the network will work.
>> --
>> This whole process is very user unfriendly - especially for for 
>> the case of a novice user (I'm not) trying to install linux for
>> the first time.  Rather than trying to put the whole book of 
>> possibilities in the installer, how about if such messages were
>> accompanied by links pointing to detailed explanations.
>As already mentioned above, reading the installation-guide might have 

Might have.  And a helpful link in the messages from the installer
might have helped.

The missing .txt (inability to find) is definitely a bug, the rest
is a matter of making the process better than it is.

Thanks for your attention -  

Reply to: