[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#909310: d-i.debian.org: Fujitsu Celsius W580 Power+n, UEFI mode, install screen unreadable



Package: d-i.debian.org
Severity: important
Tags: d-i



-- System Information:
Debian Release: 9.5
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.9.0-8-amd64 (SMP w/8 CPU cores)
Locale: LANG=ca_ES.UTF-8, LC_CTYPE=ca_ES.UTF-8 (charmap=UTF-8), LANGUAGE=ca:en_US:es:en_GB (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Note: The above system information *does not* refer to the system where I found the problem, since I
haven't been able to install or run any Debian live version on that system, and so,
haven't been able to execute reportbug in it. If asked, I'll send a list of hardware in the Fujitsu Celsius 
W580 Power+n workstation.

--

Problem: When running the Debian installer (tried jessie, stretch, buster-alpha-3 and testing), in UEFI mode, 
and reaching the first screen, where I must choose between graphical and text install (and other options),
any option I choose results in the new screen appearing on the upper part of the monitor, repeated ten
times horizontally, and shrinked so that text lines are around a couple monitor pixels tall (the whole band
of repeating screens may be around 60 pixels tall). The rest of the screen still displays the grub background. 
The shrinked repeating screen, if choosing the graphical install, shows a black screen (some white lines appear
before it gets black, which may be text) and for the text install option,
the new screen does look like the text installation screen, responding as expected to the keyboard, but
the letters are so small (around two pixels tall) that I cannot read the options. It seems
to be responding correctly to keyboard input but, of course, I cannot see what I'm doing.

Changing the graphics card, the monitor and/or graphics related BIOS options has had little effect so far
(some combinations removed the band of shrinked screens, leaving just the grub background).
I cannot try a Legacy BIOS installation, since that particular BIOS (Aptio Setup Utility, AMI, 
v2.20.1271) only allows using UEFI, and the Fujitsu web shows no updates for that BIOS.

The Ubuntu 18.04 installer did work (both for the server and desktop editions), but trying to copy 
the Ubuntu grub options and edit the Debian grub options accordingly didn't have any effect. I've
tried changing the kernel and grub options too, following some googled reports about UEFI installation
problems, with no success at all.


Reply to: