[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: Changing di-netboot-assistants directory within the TFTP-root

Hello Hermann,

On Tue, Dec 19, 2017 at 12:57:41PM +0100, Hermann Lauer wrote:
> On Mon, Dec 18, 2017 at 04:21:05PM +0300, Andreas B. Mundt wrote:


> > In di-netboot-assistant, a grub-EFI image is prepared which then
> > includes the grub.conf files of the debian-installer images, with the
> > correct paths.  You get an idea in [3].  Perhaps you can follow this
> > approach (or even better: use di-netboot-assistant) too.
> Thanks a lot, I was not aware of grub-mknetdir (and di-netboot-assistant's menu building) so far.
> OTOH, this still not answers the question if any functionality using paths relative to the
> bootnetx64.efi is available in grub.
> Should I open a bug report against grub or do you have another idea ?

When I set up di-netboot-assistant to work for EFI installs, I also
tried for some time to use the netboot image's grub, but, if I
remember correctly, it only worked to some extent with the buster
images, not with stretch.  After that I went for the more flexible
solution implemented now with an independent grub-EFI image.  However,
I am not sure if I saw the same issue you describe.

I am not sure towards which package to report the bug.  In my case I
think it's the configuration of the grub-EFI image used in the netboot
image, but I did not dive much into the issue.

If nobody more familiar with the netboot-grub-EFI stuff replies here,
you could either try to reach someone from the team setting up the
netboot images directly (perhaps also on IRC).  Maybe you could post
your first mail (the one that did not make it to the list) with a good
subject and as much details as possible again (it's not clear to me
what exactly goes wrong, i.e. TFTP server layout/configuration would be
helpful).  Right now our involved discussion will not be recognized
eventually.  If you are sure that it's a bug in grub, it should be
reported to the BTS.

Unfortunately, I have now and also in the next weeks rather limited
time to set up a test system and explore the issue further.

Hmm, could you try with buster images and see if the problem persists?

Best regards,


Reply to: