[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#862369: debian-installer: Manual installation with root on lvm/raid 1 does not boot

Control: tag -1 - moreinfo

Alfred Grimstad <agrimstad@gmail.com> (2017-05-15):
> Writing to both /dev/sda and /dev/sdb both seemed to work in the normal
> fashion during the main install process, which I've done with the Debian
> installer many times. There was no error indication.

Thanks for your syslog. This feels strange, looking at grub-installer lines:
| May 11 16:47:24 grub-installer: info: Installing grub on ''
| May 11 16:48:33 grub-installer: info: Installing grub on '/dev/sdb'

Did you pick manual selection, and entered "/dev/sda /dev/sdb" as a
destination? There's no indication grub-install was called with /dev/sda
as a parameter, which would likely explain why your installation didn't
boot if your BIOS/EFI is looking at the MBR on sda/the first disk only.

> I ran this option twice, once for /dev/sda and again for /dev/sdb.
> Based on what was written on the screen, this was equivalent to
> running:
> grub-install /dev/sd{a|b}. After that, stretch booted.

It should be, yeah.

> OK. I found /var/log/installer/syslog. I gzipped it and have attached
> to this message. I guess you're asking that I add it to the bug
> report, which I'll also try to do.

Perfect, thanks.

> > I haven't tried LVM-on-RAID1 without separate /boot yet, so I'm not
> > sure it's expected to work directly; but I know for sure that
> > LVM-on-RAID1 with separate /boot should work just fine.
> Since it was so easy for me to fix, I want to think that it wouldn't
> take much to tweak the installer to handle this case correctly too. I
> hope so, anyway. -- al

I'll wait for an answer to my question above before, but I'd tend to
think there's something fishy; so let's try and figure what and how to


Attachment: signature.asc
Description: Digital signature

Reply to: