[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#862521: Stretch RC3 - wired network non-functional after reboot

Package: installation-reports

Boot method: netboot
Image version:
Date: 2017-05-13 18:00:00 CDT

Machine: Gigabyte E350 based box-o-parts (previously had Jessie, etc.)
Processor: AMD E-350
Memory: 2G
Partitions: 100G boot & root, 2G swap

Output of lspci -knn (or lspci -nn):

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [O]
Detect network card:    [O]
Configure network:      [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Install base system:    [O]
Clock/timezone setup:   [O]
User/password setup:    [O]
Install tasks:          [O]
Install boot loader:    [O]
Overall install:        [O]

Comments/Problems: Unlike all previous releases, this time it seems it
truly needed the firmware for the Realtek NIC.  As that has never made
any difference in the past, did not install... and it had no trouble
configuring and completing the install over the network without that
driver.  So it was a shock to find that there was no working network
after rebooting.

Downloaded Realtek firmware and installed it via flash drive, and then
the network came up just as you'd expect.  But after installing a few
other things and rebooting - once again, no network.  Also, network
devices are renamed from traditional eth0 to some BSD-like unreadable
code name.  From what Google found for me, this is apparently another
"it wasn't broke, so everyone's changing it" and Debian is just running
late, but wtf?

Added section to interfaces for the unmemorable new name and that
worked after an explicit ifup... oh yeah, reboot again and see what
happens. ...  Okay, that's got it, apparently.  So perhaps it failed to
setup correctly because the firmware wasn't present during the install,
even though that (1) has never been necessary, at least for the 8168
(or similar?), and (2) the NIC worked fine all through the install.

It isn't that secrets are never needed in security.
It's that they are never desirable.  -- Whitfield Diffie

Reply to: