[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#714019: marked as done (debian-installer: Wrong $prefix in grub2 in (U)EFI mode)

Your message dated Sat, 13 May 2017 13:04:00 +0000
with message-id <2fc59c87-98b8-b77c-b57a-b37692b5fb51@a4nancy.net.eu.org>
and subject line Closing obsolete bug report
has caused the Debian Bug report #714019,
regarding debian-installer: Wrong $prefix in grub2 in (U)EFI mode
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

714019: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=714019
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: debian-installer
Severity: normal
Tags: d-i

Dear Maintainer,

When the installer is booted in (U)EFI mode, the $prefix is
/boot/grub/x86_64-efi/. As a result, all modules fail to load,
as grub2 expects them to be in $prefix/x86_64-efi.

I solved it by changing $prefix to /boot/grub and loading all the modules

I think the $prefix should be set to /boot/grub by default.

-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (900, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.9-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

--- End Message ---
--- Begin Message ---
Thanks for having taken the time to report this issue with UEFI in
Debian 7 ("Wheezy").

During last years, UEFI support has improved and we believe this bug is
likely to be solved in the current stable version of Debian 8 ("Jessie")
or in the upcoming Debian Stretch.

I'm thus closing this bug report. If you can reproduce this issue with
Debian 8 installer[1] or better with the release candidate installer for
the upcoming Debian Stretch[2], please file a new bug report.

Thanks again for your contribution!

1. https://www.debian.org/distrib/
2. https://www.debian.org/devel/debian-installer/

--- End Message ---

Reply to: