[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#706743: marked as done (EFI partition is created when installing in legacy mode)

Your message dated Sat, 13 May 2017 12:53:00 +0000
with message-id <911b8fb1-b316-70cc-649b-b97c235f84d1@a4nancy.net.eu.org>
and subject line Closing obsolete bug report
has caused the Debian Bug report #706743,
regarding EFI partition is created when installing in legacy mode
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

706743: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=706743
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---

Package: Installer
Version: CR1

I tried twice to install Debian wheezy on a laptop sold with no
operating system, Acer Travelmate P253-E, with the Bios set in Legacy
mode, the default mode that it had. The source of the installation was a
Usb memory of 8 gb with the Debian DVD of 64 bits candidate 1 and later
the weekly snapshot.
The installation process went well though it never came the screen to
select grub target device, but the installer said it had been
successful. In trying to boot, then, there was no bootable device in the
As I needed to use the computer I tried to install an Ubuntu system to
substitute the failed Debian. First surprise, Ubuntu installer prompted
to install it alongside Dabian, so I took profit of the occasion and
installed this way. Second surprise, when all was done, Ubuntu's grub
was able to boot Debian without any problem. Once in Ubuntu, I revised
the hard disc structure with Gparted and then came the third surprise:
there was a boot-efi partition created. So it seems that the Debian
installer created an unnecessary boot-efi partition that confused the
booting process of the system, which had been set always in legacy mode.
This case was not stated in Testing installation errata, so I hope this
information is useful. It has taken a while discovering it, so sorry for
not sending this note before.
Thanks for your attention,

--- End Message ---
--- Begin Message ---
Thanks for having taken the time to report this issue with UEFI in
Debian 7 ("Wheezy").

During last years, UEFI support has improved and we believe this bug is
likely to be solved in the current stable version of Debian 8 ("Jessie")
or in the upcoming Debian Stretch.

I'm thus closing this bug report. If you can reproduce this issue with
Debian 8 installer[1] or better with the release candidate installer for
the upcoming Debian Stretch[2], please file a new bug report.

Thanks again for your contribution!

1. https://www.debian.org/distrib/
2. https://www.debian.org/devel/debian-installer/

--- End Message ---

Reply to: