[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#795211: Yaboot in Jessie, following Jessie OS installation, fails to boot Mac OS X


> This is a bug that appears to crop up in the beginning of the development cycle for a version of (recent) Debians.
> I run an Apple PowerPC G5 Dual 2.0 with Apple-branded Nvidia GeForce 6800 Ultra 256 MB graphics.
> To be clear, this issue is with Jessie’s current yaboot functionality/compatibility with Mac OS X.
> Upon finishing the installation, rebooting, and seeing the yaboot boot menu (“l” for Linux, etc.) choosing “x”
> or “m” for booting my respective version of OS X (“m” was able to boot OS X “Tiger” in Wheezy) flashes the screen
> once and does not boot any OS X at all. Only “l” to boot Debian is able to work, and this necessitates alt-booting
> if I wish to boot into (an) OS X at all.

I tried installing the Debian 8.7 on my iBOOK G4, both MacOSX 10.5.8
and Debian worked well after the installation. I press "x" to boot up
the MacOSX 10.5.8 in the yaboot menu.

> I have issuing ybin -v within Debian once booted (right after installation) to see if that corrects the problem
> (I am addressing my OS X installations on a separate drive, /dev/sdb, and Debian is on /dev/sda with the yaboot
> HDD byte-codea). This did not make a difference.

Can you reproduce this issue by installing an Debian 8.7? If yes, we
can collect some data, for example: using dd to get some data from
partitions, on the newly installed Debian Linux.


Reply to: