[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#749991: Wrong kernel in debian-installer package



On Mon, 2017-03-27 at 13:32 +0200, Philip Hands wrote:
> > Alexander Sosedkin <monk@unboiled.info> writes:
> 
> > On Mon, 27 Mar 2017 12:43:40 +0200
> > > > Philipp Kern <pkern@debian.org> wrote:
> > 
> > > Even if we'd leave the old kernel udebs in testing for a while, you'd 
> > > still hit a point where we'd need to drop them and old installers
> > > would break.
> > 
> > I can see that it's impossible to support downloading modules for all
> > old ISOs.
> 
> > One can always use http://snapshot.debian.org/ as one's mirror and
> specify a dated URL that matches the ISO's creation date.

I think (based on the last few paragraphs in the "Usage" section of
that URL) that one would also need to preseed some stuff to cause it to
accept the expired signatures on that repo (with all that implies wrt
security), not sure if/how that can be done in practice though.

Ian.


Reply to: