[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#855074: RFP: installer -- [SHORT DESCRIPTION]

Hello Ben,

	thank you for your answer, here is my feedback.

Am Montag, den 13.02.2017, 21:45 +0000 schrieb Ben Hutchings:
> Control: reassign -1 installation-reports
> Control: retitle -1 installation-reports: Debian 7.9 - wrong keymap active in initramfs
> Control: tag -1 moreinfo
> On Mon, 2017-02-13 at 21:58 +0100, Rolf Heinrichs wrote:
> > Package: wnpp
> This is a bug category for planning new Debian packages or transferring
> maintainership of package, not for bugs in existing packages.
> In future, try to work out which package the bug is in, or use
> 'installation-reports' for bugs that appear on installation.

Ok, understood.

> > Wheezy amd64 7.9.0 DVD, setup with graphical installer, using Germany as
> > country, a German keyboard and setup of an encrypted drive: after boot
> > the complex key for decrypting the drive is not accepted by the
> > initramfs. The key contains special characters like capital letters and
> > characters like ~{[| that require a key combination with ALT GR on the
> > German keyboard. 
> > 
> > Also in the maintenance console, you cannot enter caps or special
> > characters.  
> This sounds similar to <https://bugs.debian.org/689851>, which affects
> use with console-tools.

Tried to reproduce on a different PC. Installations with graphical
installer with Wheezy and Jessie DVDs both worked fine, complex keys
were accepted.

Can't easily repeat on the affected PC, AMD M4A89GTD USB3 mainboard.
This mainboard has a PS2 keyboard connector. The keyboard used was a
Cherry USB keyboard with a PS2 adapter. Same problem with a native PS2
Cherry keyboard, switching to the PS2 keyboard did not fix the problem. 

Maybe the issue is dependent on some HW boundary conditions. 

> In the rescue shell, please check whether these files exist:
> - /bin/loadkeys
> - /etc/boottime.kmap.gz
> Also please try using the installer's rescue mode to start a shell in
> the installed system, and report the output of these commands:
> - grep KEYMAP= /etc/initramfs-tools/initramfs.conf
> - dpkg-query -W console-tools
> - dpkg-query -W kbd
> > Crosscheck was done with graphical installer and a simple key that did
> > not require caps or ALT GR: key is accepted. The complex key worked fine
> > when using the default CLI installer.
> > 
> > Looks like the graphical installer does not set the correct keymap.  
> There is only one installer, with these two different interface modes. 
> So it's hard to imagine why the behaviour of the installed system would
>  differ.

Unfortunately not reproducable.

Thank you, Rolf

Reply to: