[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#780118: FW: Bug#780118: Unable to install to Plain machine

This problem was, as expected, due to a mis-match between the netboot.tgz and the archives downloaded during the initial part of the installation.

The direct cause seems to be that the kernel packages may not be compatible between patch versions and this means that it was not
possible to load the kernel module for ext4 until the netboot.tgz
archive was updated on ftp.debian.org.

This is due to the kernel package not actually having any way to manage
old versions of the package (ie delete 'expired' versions) and so the
old version was, in effect, directly overwritten by the new, incompatible,

It, of course, got "fixed" once the netboot file was regenerated.

Note: For the record, I was a little unclear, but by a "plain" machine
I basically meant every machine I tried it on, two laptops and various
virtual machines.  But, I had already stated the exact installer I was
using by name and SHA1.

As this, mis-feature is part of the kernel package I suggest this bug
is closed as it has been a known 'feature' of the kernel package for
a very long time.

Thankyou for your time, I wouldn't have raised this if I'd realised
before that it was a symptom of the kernel package.

Rob.                          (Robert de Bath <robert$ @ debath.co.uk>)

On Tue, 5 Jul 2016, Robert de Bath wrote:

-----Original Message-----
From: Neil Williams [mailto:codehelp@debian.org]
Sent: 28 June 2016 12:26
To: 780118@bugs.debian.org; 780118-submitter@bugs.debian.org
Subject: Bug#780118: Unable to install to Plain machine

tag 780118 + moreinfo

On Mon, 9 Mar 2015 13:31:05 +0000 Robert de Bath <robert@tvisiontech.co.uk> wrote:
Package: debian-installer

This changed over the weekend without any change to the
'debian-installer' code itself. It was working on Friday.

I GUESS the problem will be related to packages that are downloaded
during the early part of the install; probably partman-auto.

I'm installing using the current AMD64 netboot installer.
6c27efd31f462b0954ea7ca5983ca01f633b8afa netboot.tar.gz

The disk is wiped and has no partitions. During install I selected
"Guided disk" and "Everything in one partition".

The installer creates the partitions and formats the ext4 root
partition. But is unable to mount the partition for installation of
the base system.

Rebooting and trying again does not help. There is no option to "just
use the existing ext4 partition as root"  and redoing the partitions
leaves me still unable to install.

If I do an "sfdisk -R /dev/sda" on the "ALT-F2" console it claims that
the Drive is in use and will not refresh the partition table.

This looks pretty release critical to me :-(

Apologies for the delay in responding to this but there is a lack of information in the report to be able to identify the problem.

Have you tried to reproduce this since filing the report?
How was the install run - netinst/CD/DVD, architecture, stable or testing, version, what kind of machine? ('Plain' doesn't mean a lot.)

Numerous other tests and installs have successfully happened since the bug report, so there is presumably something about how this test was done which triggered the problem.


Neil Williams

Reply to: