[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#686130: still not booting from BTRFS RAID 1 on two LVs out of the box

Am Freitag, 10. Juni 2016, 00:04:04 CEST schrieb Ben Hutchings:
> On Thu, 2016-06-09 at 18:24 +0200, Martin Steigerwald wrote:
> > Hi!
> > 
> > With todays Debian Sid/Experimental on my laptop this still doesn´t work 
> > right, I still have to add something like – I just recognized after I 
> > reinstalled initramfs-tools in a crude way after having messed it up by 
> > accidentally delete /var/lib/initramfs-tools (and then recognizing that it
> > may 
> > have been easier to recover it than what I did):
> [...]
> > So whatever local-premount/btrfs does it not sufficient for the BTRFS RAID
> > on  two LVs case.
> Indeed.  As explained in #565676, lvm2 only activates the VGs
> containing the root, /usr and hibernate/resume devices (and only if it
> can recognise that they are on LVM).  Apparently it is not generally
> safe to activate all visible VGs.  But perhaps that behaviour should be
> available as an *option*.  That is safe for most systems and I think it
> would resolve all the issues blocking this.

Any update on this? I would be fine if it was an option on kernel command line 
or so.

Well I am fine with my initramfs work-around too, but if I ever reinstall 
Debian, which is I admit unlikely as long as I use this ThinkPad T520, that 
would be nice to have.

> Ben Hutchings
> Humour is the best antidote to reality.

Nice one :).


Reply to: