[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#686130: still not booting from BTRFS RAID 1 on two LVs out of the box

On Thu, 2016-06-09 at 18:24 +0200, Martin Steigerwald wrote:
> Hi!
> With todays Debian Sid/Experimental on my laptop this still doesn´t work 
> right, I still have to add something like – I just recognized after I 
> reinstalled initramfs-tools in a crude way after having messed it up by 
> accidentally delete /var/lib/initramfs-tools (and then recognizing that it may 
> have been easier to recover it than what I did):
> So whatever local-premount/btrfs does it not sufficient for the BTRFS RAID on 
> two LVs case.

Indeed.  As explained in #565676, lvm2 only activates the VGs
containing the root, /usr and hibernate/resume devices (and only if it
can recognise that they are on LVM).  Apparently it is not generally
safe to activate all visible VGs.  But perhaps that behaviour should be
available as an *option*.  That is safe for most systems and I think it
would resolve all the issues blocking this.

(I don't really understand the purpose of running btrfs on LVM, though.
btrfs integrates logical volume management and I was under the
impression that that's the main reason to use it.  If you still need
another layer underneath then why use it at all?)


Ben Hutchings
Humour is the best antidote to reality.

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: