[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [RFC] Call for review of GNU/screen support for D-I (was Re: Merge orion5x/kirkwood to flavour marvell and marvell-qnap)

On May 9, 2016, at 8:30 AM, Roger Shimizu <rogershimizu@gmail.com> wrote:

> On Mon, May 9, 2016 at 4:21 PM, Rick Thomas <rbthomas@pobox.com> wrote:
>> Thanks, Roger!
>> I’ll give it a try on one of my sheevaplug boxes.
>> As I understand it, I will follow the instructions on Martin’s page at
>>    https://www.cyrius.com/debian/kirkwood/sheevaplug/install/
>> using the uImage and uInitrd files from your page at
>>    https://drive.google.com/folderview?id=0BzkkBTJUgwbhdjJqY1ZjY2xWem8&tid=0BzkkBTJUgwbhTldTd18yTFZCQ2s#list
> Thanks for helping to test!
> There're 4 folders in my local build for sheevaplug:
>  kirkwood/netboot/marvell/sheevaplug
>  kirkwood/netboot/marvell/sheevaplug-esata
>  kirkwood/netboot/screen/marvell/sheevaplug
>  kirkwood/netboot/screen/marvell/sheevaplug-esata
> The former two is the same as current d-i daily, without GNU/screen.
> The latter two is with GNU/screen support, which you should use.
> So, here it is:
>  https://drive.google.com/folderview?id=0BzkkBTJUgwbhM29zYnUxckQzUUk&tid=0BzkkBTJUgwbhTldTd18yTFZCQ2s#list
> Cheers,
> -- 
> Roger Shimizu, GMT +9 Tokyo

Hi Roger,

I got a chance to try it on my SheevaPlug.

Executive summary: It worked as advertised and all the features you mentioned seem to work (except I didn’t try disconnect and reconnect — see below for details).  I really liked being able to switch between VTs with a couple of keystrokes!

Here’s what I did and why I did it:

First observation is that the way I normally do installations on this machine (I keep it around for exactly this kind of testing, so I do a fair number of installations on it) is to run screen as a terminal emulator on a desktop machine that is connected to the Plug via a USB serial connection.  If I did that for this experiment, I’d wind up with screen running on the Plug inside of screen running on the Desktop and the thought of keeping track of all the levels of ctl-A gave me nightmares.

So, I changed to using “cu” to run the USB serial connection.  That worked well enough.

The installation proceeded smoothly while I experimented with the ctl-A <1-4> options.  It would have been nice to have the option of a more spacious work-area — larger than 24x80 — but that’s a minor issue.

I didn’t try disconnecting, letting it run for a while un-attended, then reconnecting because I didn’t have a clear idea of how to do that.  Specifically, what happens if I type ctl-A ctl-D?  Do I get disconnected from just the one window or all four of them?  If I get disconnected from all of them, what will I find myself talking to?  Is it an interactive shell that I can re-connect to the running disconnected screen by typing
   “screen -R”
or something else?

If I’m disconnected, can I drop the “cu” connection without causing havoc to the running install?  If I later re-instate the “cu”, what happens then? Do I automatically get my screen session back again, or is there something I need to do to to make that happen?

These are all experiments I could have done during the install, but I refrained because I wanted to verify that there weren’t any difficulties associated with simply running the installer inside screen.  Next time I get a few hours, I’ll try installing again and experiment with dis-/re-connecting.

That’s what I know now…


Reply to: