[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: No success with btrfs root on armhf

Hello again,

4th try's the charm in this case: jessie netinst (w/ USB-NIC)
Install of a minimal jessie system on btrfs root was flawless, as was the upgrade to testing. Seems like the testing version(s) of the installer don't like btrfs root, at least on this board. In any case, now everything seems to be working, except
* the onboard NIC is broken in GbE mode (being worked on)
* "kernel: /cpus/cpu@0 missing clock-frequency property" (same for @1, probably harmless)
* there's probably no video output (don't need it, haven't tried)

Stock Debian on a €45 OSHW SoC, yay! Keep up the good work!


P.S.: Should I file an installation-report?  On the successful attempt (there's #780164 already) or for the failed ones? In the latter case, how do I do that?

2016-03-20 12:58 GMT+01:00 Christian Pernegger <pernegger@gmail.com>:

I finally got back to playing around with the Olimex A20-OLinuXIno-LIME2.

1st try: d-i stretch a5 hdmedia w/ matching netinst iso
==> fails, because the installer doesn't manage to untangle the deps on upgrading ifupdown and systemd. apt-get -f install in /target works but re-running the install of the base system subsequently hangs. The log shows debconf asking for confirmation to overwrite some conf file from the first attempt, but there's no way to answer.

2nd try: d-i stretch a5 netinst (with USB-Ethernet adapter to work around the LIME2's broken GbE)
==> fails, because testing doesn't have matching kernel modules anymore. Fair enough.

3rd try: d-i stretch daily (as of ~3h ago, again w/ USB NIC)
==> works nicely ... until the reboot. I made a 256 GiB ext2 /boot [using fdisk, because d-i still can't count to 1024 ...] and the rest of the (nominally 32 GB) SD card a btrfs /root. On reboot this hangs at "Scanning for Btrfs filesystems" -- I gave up waiting after 10 min.

Should btrfs root even work on armhf?
If not, I'll just use ext4 and try again. If it should, I have the scrollback buffer of a tail -f /var/log/syslog that was running during the install, even though it's mostly in German (Anything I should sanitise in there, privacy-wise?)


P.S.: Please CC me.

Reply to: