[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#789035: debian-installer: fails to install pppoe with preseed file

Package: debian-installer
Version: 20150422+deb8u1
Severity: normal
Tags: d-i

Dear maintainer team,

I'm trying to install a fresh new jessie using a preseed file to automate most
of the task. This worked with the wheezy installer.

I downloaded the debian-8.1.0-i386-CD-1.iso, extract in on a usb key with
unetbootin, and added some files:

- syslinux.cfg to configure boot
- preseed.cfg to make some parts of install automated
- pool/main/r/rp-pppoe/pppoe_3.8-3_amd64.deb and
  pool/main/r/rp-pppoe/pppoe_3.8-3_i386.deb as they are not part of the CD1

My exact line in preseed.cfg is:

d-i pkgsel/include string openssh-server libpcap0.8 ppp pppoe openssh-client python

and it ends with the error:

in-target: package 'pppoe' has no installation candidate

and pkgsel fails with error code 100.

I had the exact same setup with wheezy, and it worked. I tried copying the
pppoe files in pool/main/p/pppoe (as a desperate try) but it doesn't work

I absolutely don't know where the problem may be, and I can make further tests
if needed.

Thanks for the job,

-- System Information:
Debian Release: 8.1
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: i386

Kernel: Linux 3.16.0-4-i386
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Reply to: