[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#774214: installation-reports: System startup fails with multiple / multi-device BTRFS mounts


and thanks for your report.

Robert Tomanek <debian@mail.robert.tomanek.org> (2014-12-30):
> Package: installation-reports
> Severity: important
> I've installed 2014-12-26 build of debian testing with btrfs as root fs -- so
> far so good, this worked fine.

So that's not really something that should be tracked through the
installation-reports pseudopackage. Let's see what we can do about it.

> Then I've created another btrfs filesystem based on 5x HDD and a
> number of subvolumes on this filesystem and then added all of them to
> fstab so that they would be mounted on boot. This is where it stopped
> working -- some of them could not be mounted automatically, but if I
> tried mounting them manually they worked fine. The open_ctree message
> in the logs is bogus I think, filesystem itself is OK.  I've fallen
> back to noauto in fstab.
> There is a matching entry on arch wiki that describes exactly my issue:
> goo.gl/JqShSo

So the real link is:

and the relevant contents:
| BTRFS: open_ctree failed
| As of November 2014 there seems to be a bug in systemd or mkinitcpio causing the following error on systems with multi-device Btrfs filesystem using the btrfs hook in mkinitcpio.conf:
| BTRFS: open_ctree failed
| mount: wrong fs type, bad option, bad superblock on /dev/sdb2, missing codepage or helper program, or other error
| In some cases useful info is found in syslog - try dmesg|tail or so.
| You are now being dropped into an emergency shell.
| A workaround is to remove btrfs from the HOOKS array in /etc/mkinitcpio.conf and instead adding btrfs to the MODULES array. Then regenerate the initramfs with mkinitcpio -p linux (adjust the preset if needed) and reboot.
| See the original forums thread and FS#42884 for further information and discussion. 

Forums thread: https://bbs.archlinux.org/viewtopic.php?id=189845
Bug report: https://bugs.archlinux.org/task/42884

The auto vs. noauto thing makes me want to query systemd people's
opinion, so I've added them to Cc. They might need further input from
you to tell us whether that's a bug or some kind of misconfiguration.


Attachment: signature.asc
Description: Digital signature

Reply to: