[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#773255: Add TI OMAP5 uEVM board support db

> On Dec 17, 2014, at 23:04, Ian Campbell <ijc@debian.org> wrote:
> On Wed, 2014-12-03 at 12:18 +0800, Chen Baozi wrote:
>> Package: flash-kernel
>> Version: 3.28
>> Severity: wishlist
>> Tags: patch
>> With the patch attached, TI OMAP5 uEVM board is supported.
> Thanks.
>> +Machine: TI OMAP5 uEVM board
>> +Method: generic
>> +U-Boot-Kernel-Address: 0x80008000
>> +U-Boot-Initrd-Address: 0x0
>> +U-Boot-Script-Address: 0x0
>> +U-Boot-Script-Name: bootscr.omap
>> +Boot-Device: /dev/mmcblk1p1
>> +Boot-Kernel-Path: uImage
>> +Boot-Initrd-Path: uInitrd
>> +Boot-Script-Path: boot.scr
>> +Required-Packages: u-boot-tools
> A few questions about u-boot on this platform:
>      * Does it support the bootz command?

The default one shipped with the board, which I got last year, seems not.
But I’m now using the latest upstream u-boot, which does support ‘bootz’.

>      * Does it support loading from "sensible" (i.e. other than FAT and
>        raw partitions) filesystems? (possibly via the generic load
>        command)?

My current upstream u-boot does support.

>      * Is /dev/mmcblk1p1 normally mounted (perhaps on /boot) or is it a
>        dedicated boot partition which is not normally mounted?

This is the partition when people use the external Micro-SD card as the
rootfs on the board. I configured my system (debian) to mount it
automatically. When I was using the old kernel last year, this partition
is recognised as /dev/mmcblk0p1. With more platform driver available,
the /dev/mmcblk0p1 is now considered to be the on-board nand flash,
which I never used. However, with the sata driver support now, one
should be able to attach a normal sata hard disk and boot the system
from it. But I haven’t tried that yet.

> Ultimately what I'm getting at is, can this platform use
> bootscr.uboot-generic? I'd like to try and default to that wherever
> possible for new platforms. (bootscr.omap predates all of the above
> facilities being generally available in u-boot AFAIK).

Oh, I haven’t had tried the boot script. I just copy this field from
OMAP4 Panda board, which is somehow similar as uEVM.

> On a separate note, there is no DTB-Id field. Does this mean that the
> platform comes with a DTB in the firmware?

No. The DTB is on the /boot too. I miss it because OMAP4 doesn’t
include this field. I guess you mentioned it because it is useful
for flash-kernel to generate the right bootscr.*?



Attachment: signature.asc
Description: Message signed with OpenPGP using GPGMail

Reply to: