[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#767042: [jessie daily 2014-10-27] [armhf] Installation report: LeMaker Banana Pi - problems with autoloading the realtek ethernet PHY driver module

Control: reassign -1 src:linux 3.16.5-1
Control: retitle -1 Linux 3.16 failing to run modprobe for libphy during installation
Control: tag -1 d-i

On Sun, 2014-11-02 at 21:43 +0100, Karsten Merker wrote:
> Following is the log from a d-i run where /sbin/modprobe and
> /sbin/insmod have been replaced by a script that logs all
> invocations of these two binaries with a "modules-debug" prefix
> before executing the original binary:
> The entry at 00:03:37 does not show a modprobe invocation before
> the initialization of the stmmac module, so the module does not
> seem to be loaded by calling modprobe, which would explain why no
> autoloading of the PHY driver happens there.  What I do not
> understand is that I also see no insmod invocation, and logging
> insmod invocations works when I run insmod from a shell. So the
> question remains: how is the stmmac module loaded at that point?
> I first thought that something might invoke kmod directly (i.e. 
> not by calling the insmod/modprobe aliases), but logging direct
> kmod invocations also shows nothing, so I am probably overlooking
> something.
> Any ideas?

So far as I can see, ethdetect runs hw-detect, which runs update-dev,
which runs 'udevadm trigger --action=add --subsystem-nomatch=sound' and
that should result in udev loading stmmac.  (udev won't have done that
when it started because the stmmac module wasn't included in the

udev is now linked with libkmod, so it can load modules without running
modprobe, and most driver modules get loaded that way.  But as I said
before, this isn't the case for the PHY driver modules.

So, I think this shows the kernel is not running modprobe for some

I'm not sure how best to investigate further.  You could add more
logging to the kernel (in kernel/kmod.c) and then rebuild the installer.
Possibly you could use systemtap for this, but it will be difficult to
install the necessary packages within the installation environment.


Ben Hutchings
A free society is one where it is safe to be unpopular. - Adlai Stevenson

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: