[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#736965: marked as done ((re)implement "missing firmware" support through kernel log grepping)

Your message dated Thu, 16 Oct 2014 21:38:01 +0000
with message-id <E1XeskD-0006QQ-6l@franck.debian.org>
and subject line Bug#725714: fixed in hw-detect 1.105
has caused the Debian Bug report #725714,
regarding (re)implement "missing firmware" support through kernel log grepping
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

725714: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=725714
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Preparing to install Debian on my new T430, which has an e1000e on eth0
and an Intel Centrino Advanced-N 6205 (supported with iwlwifi and
non-free firmware) as wlan0.

I formatted a USB stick, copied the contents of boot.img.gz,[1] copied
the netinst ISO,[2] and untarred the firmware tarball.[3]. I then booted
from the USB stick, and proceeded through the advanced installer to the
"automatically set up networking" step.

At this point, things went wrong: it decided, despite no cable being
plugged in, that it sensed a link on eth0 and tried to configure
networking. I then tried going into a shell, modprobe -r e1000e, and
then removing e1000e.ko. Now the "detect network hardware" step failed
to detect any network device; the wifi card was apparently not seen.

Then I downloaded the Wheezy 7.3.0 versions of boot.img.gz, the netinst
ISO, and the firmware tarball, and put them on the USB stick. This
detected the wifi card correctly and asked which I wanted to use to set
up networking. At this point I aborted the install, because I had yet to
install my new SSD.

 [1]: http://d-i.debian.org/daily-images/amd64/daily/hd-media/boot.img.gz
 [2]: http://cdimage.debian.org/cdimage/daily-builds/daily/arch-latest/amd64/iso-cd/debian-testing-amd64-netinst.iso
 [3]: http://cdimage.debian.org/cdimage/unofficial/non-free/firmware/

--- End Message ---
--- Begin Message ---
Source: hw-detect
Source-Version: 1.105

We believe that the bug you reported is fixed in the latest version of
hw-detect, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 725714@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Christian Perrier <bubulle@debian.org> (supplier of updated hw-detect package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@ftp-master.debian.org)

Hash: SHA256

Format: 1.8
Date: Thu, 16 Oct 2014 21:43:52 +0200
Source: hw-detect
Binary: hw-detect ethdetect disk-detect driver-injection-disk-detect archdetect
Architecture: source i386 all
Version: 1.105
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Christian Perrier <bubulle@debian.org>
 archdetect - Hardware architecture detector (udeb)
 disk-detect - Detect disk drives (udeb)
 driver-injection-disk-detect - Detect OEM driver injection disks (udeb)
 ethdetect  - Detect network hardware and load kernel drivers for it (udeb)
 hw-detect  - Detect hardware and load kernel drivers for it (udeb)
Closes: 725714
 hw-detect (1.105) unstable; urgency=low
   [ Petter Reinholdtsen ]
   * Change check-missing-firmware to look in dmesg for firmware requests
     as the linux kernel and udev no longer tell us via
     /dev/.udev/firmware-missing and /run/udev/firmware-missing which
     firmware files are needed (Closes: #725714).
 5e0aa79772766fbbda386e862f7bef2fab5d00bb 2036 hw-detect_1.105.dsc
 63fb247c5c68600aea98b52b288ebde06b0d0c5f 179420 hw-detect_1.105.tar.xz
 4aa99f08137afdf4f7eb857b955202044176d606 128548 hw-detect_1.105_i386.udeb
 0ed931b5a45d52ca1e234156c25bb48ae74f3eed 36020 ethdetect_1.105_all.udeb
 974a71ff1efd4386f9cbccdfd37a667e5e75bfdc 27600 disk-detect_1.105_all.udeb
 86f203c1acbe55ff28b5e0fa15a2e7b01b5f38d0 15118 driver-injection-disk-detect_1.105_all.udeb
 780a0739d803b554a4c6f5dbfee6aeb15fc89c90 2516 archdetect_1.105_i386.udeb
 4ab153126b6dd7290d72f96a572095de90eafd0014c86b92705d7146158fae5e 2036 hw-detect_1.105.dsc
 871c38dfca22984bbecbc0423200ef509583af210af63a759ee5e0782ee5733d 179420 hw-detect_1.105.tar.xz
 9de6de732ca96a07771a973f691884a84837b82576cd12544f2d20c8eb43b01a 128548 hw-detect_1.105_i386.udeb
 5e2c6d17f42f6ef387689f58b376fae33301242cb81c7e97aca2e952230f50db 36020 ethdetect_1.105_all.udeb
 0b3df4b78d0370475c6077a0ac2347f41c98a4dabddfdca2a8175b76de61b0c0 27600 disk-detect_1.105_all.udeb
 c882879dba95d2b8a481e936bbec86a8f9575129473dbe93a290b89a89ae2255 15118 driver-injection-disk-detect_1.105_all.udeb
 7d006a20e2885c2982eca4ba24fe632989c0ec17cc7f67e430ee54566b9c140d 2516 archdetect_1.105_i386.udeb
 ff0d0519e90014d1bb40142e3969e629 2036 debian-installer standard hw-detect_1.105.dsc
 569a7ea2f366859255db576cb8b5f827 179420 debian-installer standard hw-detect_1.105.tar.xz
 152528bd696cb926e4b66e7728f941cd 128548 debian-installer standard hw-detect_1.105_i386.udeb
 fbeba4db83a0ebc2a5295dc9dce6a762 36020 debian-installer optional ethdetect_1.105_all.udeb
 22fa6df2cef0dfea6e30f8b408d4839e 27600 debian-installer optional disk-detect_1.105_all.udeb
 513f8144f0b3cdbc590f4e9d4eb8cd81 15118 debian-installer optional driver-injection-disk-detect_1.105_all.udeb
 bbd9027904694725fadc364ce391ff29 2516 debian-installer standard archdetect_1.105_i386.udeb

Version: GnuPG v1.4.12 (GNU/Linux)


--- End Message ---

Reply to: