[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debootstrap based install difficulties with grub

I tried to follow the wheezy installer instructions to use debootstrap
to create a working system, using a preliminary wheezy system as a
base.  I ran grub inside the chroot.  The result was not bootable by

I'm using debootstrap rather then the installer to get better control
over the partitioning, and in particular to avoid having the installer
mistake many volumes for swap and want to write to them.

2 areas seemed like trouble spots, and I'm hoping someone here can
give me some guidance.

1) Setup of /dev and related file system.
I thought the first 2 methods for setting up /dev in D.3.4.1 might not
work because I wanted grub to write to the real hard disk at the end.
I tried the 3rd option, from outside the chroot in wheezy2:
mount --bind /dev wheezy2/dev
After some complaints about ttys I also mounted /dev/pts (I think I
tried both bind mounting and a direct mount -t devpts).
I also mounted /proc.
Should I have done anything about sysfs?

When grub ran it complained about not being able to find any mounts.
Should I have copied mtab?  fstab was set up.

Also, grub didn't detect any of the other OS installations on the
machine, despite having access to the devices.

2) Getting the right modules for grub and the initrd.
With my setup I needed RAID, cryptsetup, and lvm.  But from inside the
chroot none of that was obvious.  I didn't check for all of them, but
as far as I could tell there was no cryptsetup in the initrd.
I also  could not find documentation on allowed module names for

BTW, boot was a separate vanilla partition, mounted inside the chroot,
while the root file system was on a logical volume on top of crypt on
top of RAID1.

Ross Boylan

Reply to: