[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#711799: PXE error: no server is specified

I narrowed down the cause of the hangs to normal.mod, from
grub-2.02-beta2.  With vanilla upstream source the same module seemed
buggy, but instead of a hang, I got this:
> qemu: fatal: Trying to execute code outside RAM or ROM at 0x9ef000e9

The good news is, dropping normal.mod from the grub-mkimage line (used
to build d-i netboot images for non-Linux arches), I could get a rescue
shell, and it looks like the PXE issue has been fixed in this version.

I tried loading normal.mod via TFTP.  I noticed it made requests for
modules terminal and gettext as well.  So I started over, adding those
two additional modules to the grub-mkimage line.  And now it works!

It turns out those *are* listed in moddep.lst as dependencies of
normal.mod, but grub-mkimage doesn't seem to compute the dependencies
itself?  This could be either a grub-mkimage bug or limitation,

If it's the latter, grub-mkimage users need to beware of dependencies
changing in new upstream GRUB versions.  The symptom was simply a hang
or reboot, not very helpful.

I'll provide a patch for d-i shortly to at least work around it.

Steven Chamberlain

Reply to: