[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#287412: marked as done (should register-module the fan and thermal modules)

Your message dated Thu, 21 Aug 2014 19:19:06 +0000
with message-id <E1XKXt4-0001es-0T@franck.debian.org>
and subject line Bug#287412: fixed in rootskel 1.108
has caused the Debian Bug report #287412,
regarding should register-module the fan and thermal modules
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

287412: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=287412
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: rc2 netinst

Machine: hp pavilion ze4900
Processor: 686
Memory: 256 mb
Root Device: ~30 gb ide
uname -a:
Linux grebe 2.6.8-1-686 #1 Thu Nov 25 04:34:30 UTC 2004 i686 GNU/Linux

Output of lspci and lspci -n:

0000:00:00.0 0600: 8086:3580 (rev 02)
0000:00:00.0 Host bridge: Intel Corp. 82852/855GM Host Bridge (rev 02)
0000:00:00.1 0880: 8086:3584 (rev 02)
0000:00:00.1 System peripheral: Intel Corp. 855GM/GME GMCH Memory I/O Control Registers (rev 02)
0000:00:00.3 0880: 8086:3585 (rev 02)
0000:00:00.3 System peripheral: Intel Corp. 855GM/GME GMCH Configuration Process Registers (rev 02)
0000:00:02.0 0300: 8086:3582 (rev 02)
0000:00:02.0 VGA compatible controller: Intel Corp. 82852/855GM Integrated Graphics Device (rev 02)
0000:00:02.1 0380: 8086:3582 (rev 02)
0000:00:02.1 Display controller: Intel Corp. 82852/855GM Integrated Graphics Device (rev 02)
0000:00:1d.0 0c03: 8086:24c2 (rev 03)
0000:00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
0000:00:1d.1 0c03: 8086:24c4 (rev 03)
0000:00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
0000:00:1d.2 0c03: 8086:24c7 (rev 03)
0000:00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
0000:00:1d.7 0c03: 8086:24cd (rev 03)
0000:00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB 2.0 EHCI Controller (rev 03)
0000:00:1e.0 0604: 8086:2448 (rev 83)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 83)
0000:00:1f.0 0601: 8086:24cc (rev 03)
0000:00:1f.0 ISA bridge: Intel Corp. 82801DBM LPC Interface Controller (rev 03)
0000:00:1f.1 0101: 8086:24ca (rev 03)
0000:00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4) Ultra ATA Storage Controller (rev 03)
0000:00:1f.3 0c05: 8086:24c3 (rev 03)
0000:00:1f.3 SMBus: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 03)
0000:00:1f.5 0401: 8086:24c5 (rev 03)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
0000:00:1f.6 0703: 8086:24c6 (rev 03)
0000:00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 03)
0000:02:00.0 0200: 10ec:8139 (rev 10)
0000:02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:02:05.0 0607: 104c:ac50 (rev 02)
0000:02:05.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
0000:02:06.0 0280: 14e4:4320 (rev 03)
0000:02:06.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]


User install

I let the laptop's owner install it. She's a longtime linux user, but
has never done an install before. Some UI notes:

 - If the user doesn't know what partitioning is, even partman-auto's
   initial screen is hard to understand. Simply explainsing that it's how
   the disk is divided up between OS's would have helped.
 - She couldn't figure out which of the first 2 partition recipies to use
   (one partiton and desktop). She knew she wanted to use her system for a
   desktop so thought maybe the second. I had a hard time explaining why
   one ig partiton might be appropriate for a desktop install.
 - The crash explained below was handled by me, she took over again at
 - She had to be told to use space to pick tasks in tasksel. 
   She wasn't sure if she should install the mail server task -- she knew
   that she wanted a basic mail server. I had to explain that this task is
   for larger mail servers and that she'd get a basic one w/o it.
 - exim config was uncertian, but she muddled thru.
 - I was out of the room for X config, and she gave up on the fun screen
   where it asks (uselessly on i386) for a PCI ID of the video card.
 - She also didn't pick the right X driver, and apparently X didn't detect that
   she should use i810 instead of the default vesa driver. This resulted in
   bad refresh rates and flicker.
 - She didn't notice the program that was named after her. :-)
 - She read _everything_ (except syslinux help screens), and paid especial
   attention to the partman confirm screen and grub screen, just as we'd want
   an ideal user to do. (And just as we don't. ;-)
 - She wondered why passwd config wanted her full name. This is reasonable.
   We should probably mention how that info is used.


The wireless on this laptop is a broadcom and of course does not work in
the installer. Ethernet worked ok.

I later got wireless working by using ndiswrapper.

Sound crash

At reboot we got a system oops after it loaded the i810_audio module.
Annoyingly, this oops did not stop the module loading, and though the
boot later hung, it wasn't enough to trigger discover's crash detection. I
added i810_audio to discover blacklist to get around this .. only to have
to boot emergency a second time to add it to the hotplug blacklist. Argh!

Here's the oops:

Loading i810_audio module.

Intel 810 + AC97 Audio, version 1.01, 04:39:21 Nov 25 2004
ACPI: PCI interrupt 0000:00:1f.5[B] -> GSI 5 (level, low) -> IRQ 5
PCI: Setting latency timer of device 0000:00:1f.5 to 64
i810: Intel ICH4 found at IO 0x18c0 and 0x1c00, MEM 0xe0100c00 and 0xe0100800, IRQ 5
i810: Intel ICH4 mmio at 0xcea7ec00 and 0xceaf8800
i810_audio: Primary codec has ID 0
i810_audio: Audio Controller supports 6 channels.
i810_audio: Defaulting to base 2 channel mode.
i810_audio: Resetting connection 0
i810_audio: Connection 0 with codec id 0
ac97_codec: AC97 Modem codec, id: CXT48 (Unknown)
i810_audio: codec 0 is a softmodem - skipping.
Unable to handle kernel NULL pointer dereference at virtual address 00000024
 printing eip:
*pde = 00000000
Oops: 0000 [#1]
Modules linked in: i810_audio ac97_codec ndiswrapper i830 ipv6 ds parport_pc lp parport button ac 8139cp snd_ac97_codec snd_pcm snd_timer snd_page_alloc gameport snd_mpu401_uart snd_rawmidi snd_seq_device snd soundcore hw_random pciehp shpchp pci_hotplug ehci_hcd intel_agp agpgart joydev psmouse pcspkr rtc evdev mousedev tsdev usbhid af_packet uhci_hcd 8139too mii crc32 yenta_socket pcmcia_core capability commoncap battery fan thermal processor usbcore ide_cd cdrom isofs ext2 ext3 jbd mbcache ide_generic ide_disk piix ide_core unix font vesafb cfbcopyarea cfbimgblt cfbfillrect
CPU:    0
EIP:    0060:[<cee69172>]    Tainted: P  
EFLAGS: 00010246   (2.6.8-1-686) 
EIP is at i810_set_spdif_output+0x22/0x160 [i810_audio]
eax: ffffffff   ebx: 00000000   ecx: cd962c00   edx: cd962c00
esi: 00000000   edi: 00000000   ebp: cd0e8840   esp: c640be30
ds: 007b   es: 007b   ss: 0068
Process modprobe (pid: 14022, threadinfo=c640a000 task=c214a640)
Stack: 00004a06 ffffffce c011c7f4 00000000 cd0e8840 00000000 cd0e88d8 00000000 
       cee6df9f cd0e8840 ffffffff 00000000 cee6f740 c640be7c c1208580 00000a04 
       cd962c00 cee6ddb0 cd0e8870 cd962c00 00000000 00000001 00000000 00000001 
Call Trace:
 [<c011c7f4>] release_console_sem+0xc4/0xd0
 [<cee6df9f>] i810_configure_clocking+0xbf/0x4c0 [i810_audio]
 [<cee6ddb0>] i810_ac97_init+0x4a0/0x5d0 [i810_audio]
 [<cee6e84f>] i810_probe+0x4af/0x690 [i810_audio]
 [<c01aec42>] pci_device_probe_static+0x52/0x70
 [<c01aec9c>] __pci_device_probe+0x3c/0x50
 [<c01aecdc>] pci_device_probe+0x2c/0x50
 [<c01f67cf>] bus_match+0x3f/0x70
 [<c01f68fc>] driver_attach+0x5c/0xa0
 [<c01f6e21>] bus_add_driver+0x91/0xb0
 [<c01f73cf>] driver_register+0x2f/0x40
 [<c011c681>] printk+0x111/0x170
 [<c01aef5c>] pci_register_driver+0x5c/0x90
 [<cea7c01b>] i810_init_module+0x1b/0x99 [i810_audio]
 [<c0133030>] sys_init_module+0x100/0x210
 [<c0105fe9>] sysenter_past_esp+0x52/0x71
Code: 8b 43 24 8b 48 08 85 c9 75 27 0f b7 82 16 02 00 00 83 e0 fb 

After the oops it went on a bit longer and then hung somewhere in hotplug,
did not respond to ctrl-c, but typing and scrolling worked. I got similar
oopes and crashes in 2.4 and 2.6; above oops is from 2.6.

I think that this is possibly aggravated by discover/hotplug wanting to
load two sound drivers, because in addition to i810_audio, it or 
hotplug loaded snd_intel8x0 (alsa, right?). Here's how lsmod ended up
looking after I blacklisted i810_audio:

Module                  Size  Used by
snd_intel8x0           36460  0 
snd_ac97_codec         70020  1 snd_intel8x0
snd_pcm_oss            55048  0 
snd_mixer_oss          20096  1 snd_pcm_oss
snd_pcm                98728  2 snd_intel8x0,snd_pcm_oss
snd_timer              25668  1 snd_pcm
snd_page_alloc         11752  2 snd_intel8x0,snd_pcm
gameport                4704  1 snd_intel8x0
snd_mpu401_uart         7968  1 snd_intel8x0
snd_rawmidi            25156  1 snd_mpu401_uart
snd_seq_device          8200  1 snd_rawmidi
snd                    57156  9 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore              10336  1 snd

With alsa and 2.6, the sound works (I ran alsacfg, not sure if it worked
before that.) The laptop's sound buttons don't seem to do anything.


Suspend doesn't work. No big suprise there.

I was suprised to see that the acpi fan and thermal modules were not loaded
on the installed system. This seems to be an oversight in rootskel, it
loads the modules in the installer, but neglects to register-module them.

If acpid had been installed, I think it would have taken care of loading
all those modules. And it's needed for the gnome battery monitor anyway. We
need a laptop task! However, I think that even with that, unconditionally
register-moduleing fan and thermal is good from a belt and suspenders POV.


rc2 netinst has some kinda old stuff, and I noticed that one thing we don't
do is apt-get upgrade the installed system. So tasksel installs all new
stuff from the mirror, but the base system can have some kinda old
packages. From a security POV, an upgrade as part of the install would be

see shy jo

Attachment: signature.asc
Description: Digital signature

--- End Message ---
--- Begin Message ---
Source: rootskel
Source-Version: 1.108

We believe that the bug you reported is fixed in the latest version of
rootskel, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 287412@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Cyril Brulebois <kibi@debian.org> (supplier of updated rootskel package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@ftp-master.debian.org)

Hash: SHA1

Format: 1.8
Date: Thu, 21 Aug 2014 20:38:13 +0200
Source: rootskel
Binary: rootskel
Architecture: source amd64
Version: 1.108
Distribution: unstable
Urgency: medium
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Cyril Brulebois <kibi@debian.org>
 rootskel   - Skeleton root filesystem used by debian-installer (udeb)
Closes: 287412 757985
 rootskel (1.108) unstable; urgency=medium
   * Remove src/lib/debian-installer-startup.d/S05acpi-linux-x86 entirely
     following Ben's suggestion: udev takes care of such things these days
     (Closes: #287412).
   * Apply patch from Steven Chamberlain to avoid running out of space in
     the fixed-size initrd on kfreebsd-* (Closes: #757985). Use a tmpfs for
     some directories:
     - /var/cache/anna
     - /var/lib/cdebconf
 5841b0c33609f9dc732c1a0f8958fb54f892ea67 1729 rootskel_1.108.dsc
 6c252c1315bb89afb47e88979689f7a3d2c2922f 30800 rootskel_1.108.tar.xz
 03fad64cab71421efadea07d72a075339569de6b 8742 rootskel_1.108_amd64.udeb
 5ae382397e0ed0a09538c587451f493dff2d56951c5553feffceb41a7bb50ef6 1729 rootskel_1.108.dsc
 644449d64c6a90d6110b79ce5556c4922dcac072b0bf5bf3f368b322e594622e 30800 rootskel_1.108.tar.xz
 0c401161b3e336eccb090bd1da93231a5b4942cf5f12e8717523db1000be7e41 8742 rootskel_1.108_amd64.udeb
 bec6482b978a4de6d5b6e11883c5fbac 8742 debian-installer standard rootskel_1.108_amd64.udeb
 ea4b7aebaf908c2402aa0d02dddd77be 1729 debian-installer standard rootskel_1.108.dsc
 c14f4a80479f8ac29a7ebecf5716ccc6 30800 debian-installer standard rootskel_1.108.tar.xz

Version: GnuPG v1.4.12 (GNU/Linux)


--- End Message ---

Reply to: