[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#757861: debian-installer: wifi / wlan can not connect to wpa secured networks

Package: debian-installer
Version: 20140802
Severity: normal

Dear Maintainer,

   * What led up to the situation?

Try to install Debian Testing with current network-iso. Select wlan0 as network
interface (Qualcomm Atheros AR8162 (ath_9k module ?)) and connect to your WPA-
secured wlan / wifi network.

   * What was the outcome of this action?

Can not connect to network.

   * What outcome did you expect instead?

Connection working.

What does work:

Switching encryption to WEP works.

dmesg repeats (while trying to connect to WPA):

wlan0: authenticate with 00:04:xx:xx:xx:xx
wlan0: send auth to 00:04:xx:xx:xx:xx (try 1/3)
wlan0: authenticated
wlan0: associate with 00:04:xx:xx:xx:xx (try 1/3)
wlan0: RX AssocResp from 00:04:xx:xx:xx:xx (capab=0x411 stats=0 aid=1)
wlan0: associated
wlan0: deauthenticating from 00:04:xx:xx:xx:xx by local choice (reason=1)
cfg80211: Calling CRDA to update world regulatory domain

---end dmesg---

Access point: AVM FritzBox 7170

Tried to connect with other wpa secured access points and still no success.

-- System Information:
Debian Release: jessie/sid
  APT prefers testing-updates
  APT policy: (500, 'testing-updates'), (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.14-2-amd64 (SMP w/8 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Reply to: