[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

grub issues

Hi Folks,

Just installed Debian Wheezy onto a remote server, and encountered some
problems getting grub to boot properly.  I Figured it out through trial
and error, but it's pretty clear that the stock install did not configure
grub properly.

So... note sure if this is a special case that needs special handling (perhaps
better documentation), or a bug (in which case a bug report is in order). Right
now, just trying to understand what happened.

Note: Note, most of my familiarity is with grub-legacy, this is
my first time working through things with grub 2.

Step by step:

- remote install - starting w/ IPMI lan console, continuing w/ SSH

- PXEboot into the installer

- partition and configure 4 disk drives into md devices for boot, swap,
root, LVM

- USB drive shows up as /dev/sda during install - with hard drives as

- after install hard drives show up as /dev/sda-d, usb drive as /dev/sde

- pretty standard install process until the end

- between the RAID devices and the USB stick as /dev/sda - had to fiddle a
bit to install MBR into hard drives

- attempted to boot, end up at grub prompt on the remote console

- typed "boot" and got "error: no kernel loaded"

<clearly something was not installed/configured properly>

- did some googling, based on what I found, tried the following (from
the grub> prompt)
-- set prefix=(md/0)/boot/grub
-- set root=(md/2)
-- boot
-- still get "error: no kernel loaded"

-- noted that ls (md/0)/ showed System.map, config-, vmlinuz, initrd as
well as grub
-- tried the command "linux (md/0)/vmlinuz..." - let it autocomplete the
full file name
----- got "error: file not found"  #THIS IS CONFUSING - SINCE LS AND

-- insmod normal
-- insmod
------ now I get a boot screen, and after the timeout, everything booted

- reboot brought be back to the grub> prompt

- this time, after booting:
-- ran update-grub and grub-install on all four drives, and and on
/dev/md0 (boot) and /dev/md2 (root) for good measure
-- rebooted - everything came up fine So problem is solved but 2 questions

So... it seems like the installer is doing something different, and wrong, as
compared to update-grub and grub-install.
- could be a bug
- could be that I needed to do something special during the install procedure

Perhaps somebody could shed some light on what's going on, and if this warrants
a bug report or documentation input, point me in the right direction to do so?


Miles Fidelman

p.s So far - no input whatever from either the debian-user list or the help-grub list.

Reply to: