[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#582101: marked as done (debian-installer: boot on raid mdadm fails after installation (raid1 + LVM) "similar superblocks)

Your message dated Fri, 26 Apr 2013 22:28:27 -0400
with message-id <CANTw=MPmEavskGqJ4D7h3t+-noqNCUrPSRgJAwQ4XajoCosf=Q@mail.gmail.com>
and subject line re: debian-installer: boot on raid mdadm fails after installation (raid1 + LVM)
has caused the Debian Bug report #582101,
regarding debian-installer: boot on raid mdadm fails after installation (raid1 + LVM) "similar superblocks
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

582101: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=582101
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: debian-installer
Version: 20100211
Severity: important

-- System Information:
Debian Release: 6.0
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i586)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.32+25
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

After installing a Debian/Squeeze with RAID1 and Logical Volumes, the
freshly installed system does not boot.

Error message at first boot:
mdadm  /dev/sdb1 and /dev/sdb appear to have very similar superblocks.
Please zero-superblocks on one of the device. Devices overlap.

System goes to initrd prompt. Not possible to activate RAID1 unit /dev/md0
mdadm always report the same error when activating the RAID1.

system is having a
/boot device on /dev/hda (/dev/hda1)
/dev/sda and /dev/sdb with one primary partition marqued for RAID
/dev/md0 is used as a PV, there is one Volume Groupe vg01 and 3 logical
volumes : /dev/vg01/lvol1-root /dev/vg02-swap and /dev/vg03-home

If I boot the unbootable system with a live CD, I manage to activate the
MD and the LVM on it and do it manually.

Installing a Debian Lenny instead of Debian Squeeze solved the problem.
/dev/hda is on compact flash card 4G
/dev/sda and /dev/sdb are brand new 500Gb Seagate Barracuda 7200.12

Grub boots, but as soon as the system is looking for a root filesystem,
it stops waiting, because the RAID array is not ready.

I tried to force --zero-superblocks on the device /dev/sda and /dev/sdb
from a liveCD but it doesn't change.

It makes the system uninstallable on classical RAID1 configuration with 
separate /boot partition

--- End Message ---
--- Begin Message ---
I just did an installation with the exact same configuration, and it
went just fine.  Anyway, this was reported 3 years ago and a lot has
changed since then, so I can't really say what the fix was.  Although,
if you're still experiencing this the wheezy installer, please reopen
the bug.

Best wishes,

--- End Message ---

Reply to: