[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PowerPC bootp+tftp Network Boot: "method 'load' failed 00000300, newer yaboot version, alternate kernel images

Oh, well.
I used the bootpd and tftpd that ship with OS X10.5 (not the server edition). If you want to do the same,  then do this:

Tweak /etc/bootpd.plist* to disable all dhcp features, since your home network probably already has a DHCP server, and Open Firmware only does bootp, prior to version 3.

Put an entry in  /etc/bootptab* for the target system, giving it the same IP the DHCP server gives it when it's fully booted into an OS, [and putting in "yaboot" for the bootfile. (this doesn't actually work)]**

Enable the daemons with launchd, like this:
sudo launchctl load -F /System/Library/LaunchDaemons/tftpd.plist
sudo launchctl load -F /System/Library/LaunchDaemons/bootps.plist
(the -F is to override the "Disabled" string in the plists, which prevents them from coming up on [re]boot)

Copy all the files from the mirror to /private/tftpboot/

Bring the target system up in Open Firmware, type in: boot enet:0,yaboot [if the bootfile entry had worked, then you could, theoretically, just hold the N key down, instead of invoking Open Firmware]

Install! Or do a dry run, i guess.

*The OS X bootpd does not use the same syntax! see:

**for reasons which I cannot fathom, OS X's bootpd prepends "/private/tftpboot/" on the bootfile path it sends to the target system, unless the bootfile path in the bootptab is already an absolute path. For reasons which I cannot fathom, the tftpd throws an error code 2 if you try to fetch files by anything other than a path relative to /private/tftpboot, with NO leading / allowed. This means that using the Netboot hotkey on the target system won't work, you must use the Open Firmware prompt

OR, you could just install a tftpd and bootpd on your Linux box, configure more or less the same, copy the files to the correct dir, and bring up the target in Open Firmware. booting with the same command (you can probably omit the ",yaboot" in this case)

On Thu, Oct 25, 2012 at 12:41 PM, Rick Thomas <rbthomas@pobox.com> wrote:

On Oct 25, 2012, at 11:39 AM, Patrick Fitzmorris wrote:

(does anyone test the functionality of the ppc
netboot images anymore?)

Well, I try...  I have a number of old PowerPC Macs that I keep just for the purpose.  I haven't tried network booting yet.  Can you give me some pointers on how it's done?



Reply to: