[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#675294: installation-reports: "No disk drive was detected" during 6.0 install

On Wed, May 30, 2012 at 10:20:36PM -0400, Mike Bianchi wrote:
> Package: installation-reports
> Severity: grave
> Tags: d-i
> Justification: renders package unusable
> While installing squeeze from a netinstall cd, after entering the user name and password,
> the message "No disk drive was detected" came up with a list of driver names.
> The drive is a new SATA 6.0Gb/s on an Intel DZ68BC mother board + I5-2500K processor.
>  The blue SATA cable was wired to the SATA 6 connector on the MoBo.
> The fix was to use a red SATA cable wired to the SATA 3.0 connector during the install.
>  Afterwards, the 6.0 connection fails --
>  grub starts and lets me select the Debian entry or the recovery entry, but the boot fails
> with a message that it cannot find /dev/disk/by-uuid/15f48ced-09a9-43a7-be73-c0fd7554dc14 .
> Switching back to the 3.0 connector lets me run the system, which is a get-around I'm using now.
> I'm guessing there isn't SATA 6.0 support.

There is, but not for that Marvell controller.

If you were to install the 3.2.0 kernel from backports, it should work
with the SATA 6.0 controller.

> Comments/Problems:
> <Description of the install, in prose, and any thoughts, comments
>       and ideas you had during the initial install.>
> Before I installed squeeze, I installed Suse 12.1 on /dev/sda2,
>  Xubuntu 12.04 on /dev/sda6,
>  Ubuntu 12.04 on /dev/sda7
> All worked with the 6.0 SATA connection. 

> I strongly suspect they benefit from using Linux kernel 3.2.0 .

Absolutely correct.

> Please make sure that the hardware-summary log file, and any other
> installation logs that you think would be useful are attached to this
> report. Please compress large files using gzip.
> Once you have filled out this report, mail it to submit@bugs.debian.org.
> ==============================================
> Installer lsb-release:
> ==============================================
> DISTRIB_DESCRIPTION="Debian GNU/Linux installer"
> DISTRIB_RELEASE="6.0 (squeeze) - installer build 20110106+squeeze4+b1"
> ==============================================
> Installer hardware-summary:
> ==============================================
> uname -a: Linux foveal5 2.6.32-5-amd64 #1 SMP Sun May 6 04:00:17 UTC 2012 x86_64 GNU/Linux
> lspci -knn: 00:1f.2 SATA controller [0106]: Intel Corporation Cougar Point 6 port SATA AHCI Controller [8086:1c02] (rev 05)
> lspci -knn: 	Subsystem: Intel Corporation Device [8086:201c]
> lspci -knn: 	Kernel driver in use: ahci
> lspci -knn: 06:00.0 IDE interface [0101]: Marvell Technology Group Ltd. Device [1b4b:91a3] (rev 11)
> lspci -knn: 	Subsystem: Intel Corporation Device [8086:201c]
> lspci -knn: 07:00.0 IDE interface [0101]: Marvell Technology Group Ltd. Device [1b4b:91a3] (rev 11)
> lspci -knn: 	Subsystem: Intel Corporation Device [8086:201c]

This Marvell AHCI/RAID 6Gbps SATA controller was only added around 2.6.37,
so 2.6.32 in debian stable will not detect it.

The intel AHCI SATA controller above on the other hand is supported
which is why that works for you.

Len Sorensen

Reply to: