[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Wheezy on multi-device btrfs-only setup


(Please CC me, I'm not subscribed to this list.)

I posted to debian-user about this earlier and got the suggestion to try
it here.

Basicly I installed Wheezy using a daily build of the Debian installer
(amd64 netinstall) and after jumping through some hoops, I was able to
get Debian installed on a 6 drive btrfs file system using raid10.
All devices are 3 TB in size and use GPT, all of them have 2 partitions:
BIOS boot (flagged as bootable in gdisk) and regular linux filesystem
used for btrfs.

I used an Ubuntu 12.04 to set up the partitions (subvolumes for /
and /home, with the once for / as the default, I figured I could
move /home to its proper subvolume later), then using d-i I switched to
a shell and ran btrfsctl -a (equivalent of "btrfs device scan"). Once
the scan is complete (already at the partitioner at that point in the
installation) I could select a single btrfs partition from those 6
devices and mark it to be used as the root filesystem (and only file
system). Installation continued normally until the GRUB installation
step. Installation of GRUB failed, skipping that step, I have a
completely installed system without a boot loader.

Using rescue mode on the d-i I tried numerous times to get either GRUB
or extlinux (syslinux) to be used for the bootloader. Both to no avail.
As far as I can see, grub-install fails because of grub-probe:

# grub-probe /dev/sdb2
grub-probe: error: cannot find a device for /dev/sdb2 (is /dev

Am I correct in the assumption that grub-probe cannot cope with a
multi-device btrfs file system? Or is there some way around this?
Also I'm not a fanatic GRUB user, any working bootloader will do.

Can this be solved somehow, short of using a separate /boot partition?

Kind regards,

PS: link to the original discussion

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: