[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#668923: debian-installer: Installing grub fails: /boot on raid1; / on lvm2 on dm-crypt on raid

Package: debian-installer
Version: testing
Severity: important

Dear Maintainer,

   * What led up to the situation?
	I tried installing Debian using the partition layout provided in the gentoo wiki: http://en.gentoo-wiki.com/wiki/Root_filesystem_over_LVM2,_DM-Crypt_and_RAID
   * What exactly did you do (or not do) that was effective (or
	I went through the steps of debian-installer, configured the partitions like described above.
	This is the output of gdisk (its for /dev/sda , but /dev/sdb is the same)
GPT fdisk (gdisk) version 0.8.2

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 1953525168 sectors, 931.5 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 853F5A88-B593-4BFC-88BC-DC825FB9BD90
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 1953525134
Partitions will be aligned on 2048-sector boundaries
Total free space is 2014 sectors (1007.0 KiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048            4095   1024.0 KiB  EF02  
   2            4096          585727   284.0 MiB   FD00  
   3          585728      1953525134   931.2 GiB   FD00  

   * What was the outcome of this action?
	Grub install failed with an fatal error ( http://pastebin.com/2akhkUCR )
	I tried around a little bit and discovered that the boot partition wasn't mounted at /target/boot while all other partitions were mounted at there respective place in /target.
	Instead there was just a folder /target/grub with all the files that should have been gone to the boot partition.
	After moving that folder to /target/bootbak, creating /target/boot, mounting /dev/md0 (the boot partition) there, copying all files from bootbak to boot (which is probably unnecessary) debian-installers "Install Grub bootloader" worked :)
	So probably debian-installer missed mounting /dev/md0 to /target/boot so grub install failed.
   * What outcome did you expect instead?
	Grub should have been installed without problems / the boot partition should have been mounted at /target/boot automatically

This problem occured as well with debian stable (but in a vm) and I didn't check whether the missing boot partition was the root of the problem there as well.
In my "real-world" installation the error occured both, with the above described partition setup and one with msdos partitiontable. But same goes here, I didn't check whether the missing boot partitin caused the problem there as well.

Furthermore /dev/md0 /boot was missing in /fstab. Instead the usb stick I installed from was in there to mount to /mnt/usb1 (or another number, can't remember).

-- System Information:
Debian Release: wheezy/sid (<-- I'm using testing, dont know what the sid does there, reportbug created this section..)
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 3.2.0-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Reply to: