[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#655333: marked as done (installation-report: no graphical install, btrfs I/O errors, configuring grub failed)

Your message dated Sun, 01 Apr 2012 12:17:06 +0100
with message-id <4F783932.5080000@debianpt.org>
and subject line 
has caused the Debian Bug report #655333,
regarding installation-report: no graphical install, btrfs I/O errors,  configuring grub failed
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

655333: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=655333
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports
Version: 2.45
Severity: important

Dear Maintainer,

When I tried the graphical install, it just hang.

So I continued with the non-graphical install.

After partitioning (choosing btrfs for all but the swap partition), when installing the base system the root partition almost immediately gave I/O errors.

So I went back and chose ext4 for all partitions instead.

The configuring bootloader step (grub2 in my case) failed without obvious error message, so I went back, opened a console and fixed it manually. Only choosing continue without boot loader did work from there.

Afterwards I had problems with the new gnome-shell, only the fallback works. But that has probably nothing to do with the installer.

-- Package-specific info:

Boot method: CD
Image version: http://cdimage.debian.org/mirror/cdimage/unofficial/non-free/cd-including-firmware/daily-builds/sid_d-i/current/amd64/iso-cd/firmware-testing-amd64-netinst.iso downloaded on January 6th
Date: January 6th

Machine: Dell Optiplex 780
Filesystem               Type     1K-blocks    Used Available Use% Mounted on
rootfs                   rootfs     9611492 2199432   6923820  25% /
udev                     devtmpfs   1940464       0   1940464   0% /dev
tmpfs                    tmpfs       389312     324    388988   1% /run
/dev/mapper/filotes-root ext4       9611492 2199432   6923820  25% /
tmpfs                    tmpfs         5120       0      5120   0% /run/lock
tmpfs                    tmpfs      9031048  151496   8420800   2% /tmp
tmpfs                    tmpfs       778624     536    778088   1% /run/shm
/dev/mapper/filotes-home ext4     210616752  221776 199696224   1% /home
/dev/mapper/filotes-tmp  ext4       9031048  151496   8420800   2% /tmp
/dev/mapper/filotes-var  ext4       2882592  955632   1780528  35% /var

Base System Installation Checklist:

[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [O]
Detect network card:    [O]
Configure network:      [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Install base system:    [E]
Clock/timezone setup:   [O]
User/password setup:    [O]
Install tasks:          [O]
Install boot loader:    [E]
Overall install:        [O]


Obviously the OKs after the Errors only happened when I worked around them.

Like I said above, the graphical installer just hang after choosing it. I had to do a hard reboot to get back to the installer.

I chose to use LVM. The boot partition was always plain ext4. When I chose btrfs (on LVM) for all other partitions (except swap), the base install spawned a gazillion I/O errors for the root partition. So I went back and chose ext4 (on LVM) instead.

When configuring the boot loader (grub2), it showed me a progress bar and almost immediately a red message telling me it failed. So I went back, chose to open a console where I did the following:

# chroot /target
# update-grub
inspected the /boot/grub/grub.cfg file
# grub-install /dev/sda
# ^D
# exit

Then I chose to continue without bootloader and it rebooted fine in the installed system.



--- End Message ---
--- Begin Message --- Graphical install issues were recently fixed: no mouse/keyboard response as well as the black screen issue.

BTRFS errors were fixed with the recent inclusion of the linux-image-3.2.0-2 kernel.

Although this is fixed there are still other problems with BTRFS installation with d-i (grub-installer). See bugs #666559 and #662086.

Melhores cumprimentos/Best regards,

Miguel Figueiredo

--- End Message ---

Reply to: