[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#660181: debian-installer: kernel panic on first boot "Unable to mount root fs"

Package: debian-installer
Version: wheezy 20110106+squeeze4 debian-testing-i386-netinst.iso
Severity: important

Dear Maintainer,
*** Please consider answering these questions, where appropriate ***

   * What led up to the situation?
Target system: Compaq DL380-G1 which has an integrated SCSI disk controller (cpqarray)
I have installed Debian previously fine under LILO boot, system got hosed and required new install

This time:
- netinstall from CD fine, 
- installer suggested to include cpqarray which was selected
- first reboot after install fails with kernel panic:

List of all partitions:
No file system count mount root, tried:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block (72,1)

   * What exactly did you do (or not do) that was effective (or

tried both kernels offered in install options

   * What was the outcome of this action?


   * What outcome did you expect instead?

kernel/install to handle inclusion of method/module providing disk access through the disk controller (cpqarray) at boot time (assumption that this causees the problem

there are the following modules on the new install partition which crashes:


and /etc/init.d/cpqarrayd with links in all the rc?.d's

*** End of the template - remove these lines ***

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: 3.2.0-1-686-pae  (x86_32)

Kernel: Linux 3.2.0-1-686-pae an 3.2.0-1-386
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Reply to: