[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#636398: debian-installer: d-i fails to mount USB device when a preseed configuration file is passed as kernel argument

Package: debian-installer
Version: sid
Severity: important
Tags: sid

I am trying to install Debian Wheezy with the latest daily buils of sid
installers available. I tried both the netboot image for powerpc:
1. http://d-i.debian.org/daily-images/powerpc/daily/powerpc/netboot/mini.iso
and the netisntall image:
2. http://cdimage.debian.org/mirror/cdimage/daily-

In both cases I remastered the images to include a preseed.cfg file. I will
start with the netboot image:

1. netboot daily build 02.08.2011 00:05 16M)
Very early in the installation it fails to load the debconf preconfiguration
file. "The file needed for preconfiguration could not be retrieved from
file:///cdrom/preseed.cfg". Syslog reports:
INFO: Menu item 'file-preseed' selected
WARNING: Configuring 'file-preseed' failed with error code 1

It should be noted that my USB device (/dev/sda) showed up in syslog with
dmesg. The device could not be manually mounted in a busybox shell.

2. netinstaller (daily build #5 for PowerPC 02.08.2011)
Problem at hardware detection of CDROM again. In syslog /dev/sda showed up.
cdrom-detect: Searching for Debian installation media...
cdrom-detect: Devices: '/dev/hde'
cdrom-detect: CD-ROM mount failed: device=/dev/hde fstype=iso9660
cdrom-detect: mount: mounting /dev/hda1 on /media failed
it then tried all other partions hda2-hda7 of my hard disk
It also tried to find a floppy device on /dev/fd0
The installer did not consider to try /dev/sda.
Manually mounting /dev/sda on /cdrom worked in a busybox shell.

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: powerpc (ppc)

Kernel: Linux 2.6.32-5-powerpc
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Reply to: