[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#531316: [debootstrap] --foregin for kfreebsd-* fails still - debootstrap to kfreebsd from Linux not possible.

Package: debootstrap
Version: 1.0.32

--- Please enter the report below this line. ---
Have the same error on debootstrap 1.0.26+squeeze1 from Squeeze and for 1.0.32 (exactly the same result). I wanted to debootstrap from Linux to kFreeBSD, run: debootstrap --foreign --arch=kfreebsd-i386 squeeze /mnt/temp http://ftp2.de.debian.org/debian/

Package extraction is OK, but then I get:
W: Failure trying to run: chroot /mnt/temp mount -t devfs devfs /dev

in /usr/share/debootstrap/functions there is:

setup_devices () {
        case "$ARCH" in
                in_target mount -t devfs devfs /dev ;;

looks like it should work...

There is /dev/sda5, formatted as ext2 mounted as /mnt/temp.


--- System information. ---
Architecture: i386
Kernel:       Linux 2.6.32-5-686

Debian Release: 6.0.2
  500 stable-updates  ftp.fi.debian.org
  500 stable          security.debian.org
  500 stable          ftp.fi.debian.org
  500 stable          deb.opera.com
  400 unstable        ftp.fi.debian.org
  100 experimental    ftp.fi.debian.org

--- Package information. ---
Depends      (Version) | Installed
wget                   | 1.12-2.1

Recommends                  (Version) | Installed
gnupg                                 | 1.4.10-4
debian-archive-keyring                | 2010.08.28

Package's Suggests field is empty.

Reply to: