[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#617483: installation-reports: After install on external firewire, display hosed and can't boot into Mac OS X

Package: installation-reports
Severity: important

*** Please type your report below this line ***

-- Package-specific info:

Boot method: CD
Image version: http://cdimage.debian.org/debian-cd/6.0.0/powerpc/iso-cd/debian-6.0.0-powerpc-netinst.iso
downloaded 7 March 2011
Date: 8 March 2011 AM

Machine: Apple Dual USB iBook (500 Mhz 384MB + Western Digital 80GB
external Firewire)

fdisk -l
        #                    type name                  length   base
    ( size )  system
/dev/sda1     Apple_partition_map Apple                     63 @ 1
    ( 31.5k)  Partition map
/dev/sda2         Apple_Bootstrap untitled                1954 @ 64
    (977.0k)  NewWorld bootblock
/dev/sda3         Apple_UNIX_SVR2 untitled           154054688 @ 2018
    ( 73.5G)  Linux native
/dev/sda4         Apple_UNIX_SVR2 swap                 2244733 @
154056706 (  1.1G)  Linux swap
/dev/sda5              Apple_Free Extra                     49 @
156301439 ( 24.5k)  Free space

Block size=512, Number of Blocks=156301488
DeviceType=0x0, DeviceId=0x0

        #                    type name                 length   base
  ( size )  system
/dev/hda1     Apple_partition_map Apple                    63 @ 1
  ( 31.5k)  Partition map
/dev/hda2        Apple_Driver_ATA Macintosh                64 @ 64
  ( 32.0k)  Unknown
/dev/hda3        Apple_Driver_ATA Macintosh                64 @ 128
  ( 32.0k)  Unknown
/dev/hda4           Apple_Patches Patch Partition         512 @ 192
  (256.0k)  Unknown
/dev/hda5               Apple_HFS MacOS              19640166 @ 704
  (  9.4G)  HFS
/dev/hda6              Apple_Free                          10 @
19640870 (  5.0k)  Free space

Block size=512, Number of Blocks=19640880
DeviceType=0x0, DeviceId=0x0
1: @ 64 for 21, type=0x701
2: @ 128 for 34, type=0xf8ff

df -Tl

Filesystem    Type   1K-blocks      Used Available Use% Mounted on
/dev/sda3     ext3    75818104  15353648  56613092  22% /
tmpfs        tmpfs      191572         0    191572   0% /lib/init/rw
udev         tmpfs      186592       164    186428   1% /dev
tmpfs        tmpfs      191572         0    191572   0% /dev/shm

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [O]
Detect network card:    [O]
Configure network:      [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Install base system:    [O]
Clock/timezone setup:   [O]
User/password setup:    [O]
Install tasks:          [O]
Install boot loader:    [E]
Overall install:        [E]


I chose Debian because it still supports PPC. Kudos for that. I tested
my computer before starting the installation, and noted that by holding the "t"
key down during startup, it would try to boot from the firewire port.

During the "Partition hard drives", I instructed the installer to use the whole
Firewire Disk, and to leave the internal drive untouched. Everything
went smoothly
until it was time to reboot.

I held down the "t" key and started the computer. All that happened
was I saw the
same firewire symbol that I saw before the install.

I restarted the computer and got a dialog offering the choices "old"
and "Linux". I
chose "old". The computer seemed to hang at the grey screen with the
Apple logo. After
5 minutes I pulled the plug and restarted. This time I chose "Linux".

The computer seemed to boot, and after a short while I got a quarter inch wide
horizontal grey stripe an inch and a half from the bottom of the
screen. I recall
reading about something like that when investigation the various distributions.

Because my intention was to create a server, I had configured the
machine for ssh.
I was able to log in via ssh, which is how I am able to send you this report.

Thoughts, comments, etc.

"The operation was a success; unfortunately, the patient died!"

1) I had expected the installer to leave my internal hard drive
untouched, and to
install a boot partition on the firewire drive. I had expected to boot
into Debian
by holding down the "t" key during startup, similar to how I held down
the "c" key
to boot from the Debian installer CD. I am not an fdisk guru, but it seems to me
that there is a bootblock on the external drive, but no longer a
bootblock on the
internal drive.

2) I have no idea why the hold down the "t" thing doesn't work.

3) The grey striped display thing is why I labeled the severity: important. If I
had not configured ssh during the install, the install would have been
a total fail.

4) In addition to the grey stripe, I don't know how to dim or turn off
the display.
It doesn't turn off when I close the lid, and it hasn't gone to sleep
yet after 36 hours.
Interesting note: I just tried using the F1 key, which is supposed to
dim the screen.
A 3.5" H x 7.75" W tan box appeared. The bottom left corner of the box
is 1.5" from the
bottom and flush with the left edge. I hope this doesn't burn a
permanent strip onto
the display.

5) My previous Linux experience is CentOS, which uses RPM. Aptitude is

6) I downloaded
http://libtorrent.rakshasa.no/downloads/libtorrent-0.12.7.tar.gz and
http://libtorrent.rakshasa.no/downloads/rtorrent-0.8.7.tar.gz. It was
a straightforward
install on CentOS. I ran into a number of problems on Debian until I
became aware that
the system had no development tools. Cut to the chase: rtorrent is up
and running.

Finally, a little story just to let you know how clueless I am. I
started using computers
in high school in 1965. I bought an Apple ][+ in 1980, and a Mac 128k
in 1984. I bought
this iBook for my daughter in 2001. I got it as a hand-me-down when my
daugher bought a
PowerBook. She has since moved on to a MacBook Pro.

Two years ago, the return (enter) key stopped working. You can not log
on to Mac OS X
without using the enter key. So for the past two years I have used a
Dell keyboard via a
PS/2 to USB converter just so I could use the enter key.

It wasn't until last Saturday that I realized that the iBook keyboard
has TWO enter keys,
and the one to the right of the CMD key still works just fine!

Clueless. It's possible that I overlooked something during the install.


Please make sure that the hardware-summary log file, and any other
installation logs that you think would be useful are attached to this
report. Please compress large files using gzip.

Once you have filled out this report, mail it to submit@bugs.debian.org.

-- System Information:
Debian Release: 6.0
  APT prefers squeeze-updates
  APT policy: (500, 'squeeze-updates'), (500, 'stable')
Architecture: powerpc (ppc)

Kernel: Linux 2.6.32-5-powerpc
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Reply to: