[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#614548: Grub installation on mdadm raid-0 array fails

A Terça 22 Fevereiro 2011 07:46:05 mplia mpliaaa você escreveu:
> Package: Debian-Installer
> Version: 6.0
> Description: By default, the Squeeze installer uses mdadm metablock version
> 1.2 when it creates a new raid-0 array. This results in grub not being able
> to install, since there's obviously an incompatibility between grub and
> this new metablock version. A workaround on this issue is to boot via a
> livecd and build the array using the --metablock=0.90 parameter on mdadm.
> Then reboot with debian and install squeeze on this pre-made array (grub
> installs properly).
> Solution: see above. Perhaps the squeeze installer should use the
> --metablock=0.90 parameter by default?

grub-pc installed was: 1.98+20100804-14. 

This is what happened when i tried to install with RAID0:

Mar  8 09:43:52 grub-installer: info: Installing grub on '/dev/sda'
Mar  8 09:43:52 grub-installer: info: grub-install supports --no-floppy
Mar  8 09:43:52 grub-installer: info: Running chroot /target grub-install  --
no-floppy --force "/dev/sda"
Mar  8 09:43:53 grub-installer: /usr/sbin/grub-probe: error: unknown 
Mar  8 09:43:53 grub-installer: Auto-detection of a filesystem of /dev/md0 
Mar  8 09:43:53 grub-installer: Please report this together with the output of 
"/usr/sbin/grub-probe --device-map=/boot/grub/device.map --target=fs -v 
/boot/grub" to <bug-grub@gnu.org>
Mar  8 09:43:53 grub-installer: error: Running 'grub-install  --no-floppy --
force "/dev/sda"' failed.

...but i did another installation with RAID1 and it was sucessfull and the 
system boots. 
It is also using version 1.2 as in the previous installation in RAID0.

Melhores cumprimentos/Best regards,

Miguel Figueiredo

Attachment: gruberror.png
Description: PNG image

Reply to: