[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#615926: busybox-udeb: missing shaXYZsum binaries

found 615926 1:1.17.1-8
notfound 615926 1:1.17.1-10

On Tue, 1 Mar 2011 12:17:18 -0400 Joey Hess wrote:

> Thijs Kinkhorst wrote:
> > On Tue, March 1, 2011 05:21, Michael Gilbert wrote:
> > > package: busybox-udeb
> > > version: 1:1.17.1-10
> > > severity: grave
> > >
> > > Hi, testing is currently uninstallable since debootstrap (as of 1.0.28)
> > > no longer uses md5 for integrity checks.  It can make use of various
> > > shaXYZsum instead.  I think providing sha1sum should be sufficient, but
> > > it may make sense to provide more than that.
> > 
> > The version you quote (which is not yet in testing) provides sha256sum. Is
> > that not sufficient then?
> Downgrading this bug as it'll be preventing the fix from reaching
> testing.
> If this version of busybox-udeb actually does not work, I second Thijs's
> request for details.

I was busy working on other things and blindly accepted the version
number from my unstable box where I generated the bug report, not the
actual vm where I ran into the issue.

Having sha256sum available may be enough, but I haven't looked at that.

> Note that base-installer 1.116 is also needed, and also not yet in
> testing. Really, it's fairly pointless to be using wheezy_d-i CD images
> at this point in the development cycle. Perhaps the fix for this is
> just to point the CD symlinks at the sid_d-i images.

I'm generating nightly testing snapshots, and those are incapable of
completing an installation right now due to this issue, which is why I
submitted this.

This may be a bit premature, but my monthly snapshots may be a better
resource to direct users to that want a reliable testing installer.
Well, at least that's the goal anyway ;)

Best wishes,

Reply to: