[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#610526: marked as done (Preseed: Debian Installer ignores hostname parameter)

Your message dated Tue, 25 Jan 2011 15:18:45 +1100
with message-id <20110125041845.GC3231@hezmatt.org>
and subject line Re: Bug#610526: Preseed: Debian Installer ignores hostname parameter
has caused the Debian Bug report #610526,
regarding Preseed: Debian Installer ignores hostname parameter
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

610526: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=610526
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: debian-installer
Version: 20090123lenny8
Severity: normal


i have added the following lines to the file "isolinux/txt.cfg", but the
Debian Installer ignores the hostname parameter.

label basic
        menu label ^Install basic
        kernel /install.386/vmlinuz
        append  auto=true priority=critical vga=791
initrd=/install.386/initrd.gz file=/cdrom/preseed/basic.cfg
DEBCONF_DEBUG=5 hostname=basic -- quiet

After the installation the hostname is set to "unassigned-hostname".

This Problem only exists with the current lenny release (5.0.7). It
worked with earlier releases and the daily squeeze build.

Regards, Dennis

Attachment: signature.asc
Description: OpenPGP digital signature

--- End Message ---
--- Begin Message ---
On Mon, Jan 24, 2011 at 09:37:18PM +0100, Dennis Hoppe wrote:
> Hello Matthew,
> maybe this log file can help you. As you see i have set the hostname in
> the beginning as kernel parameter, but the installer is setting it as
> "unassigned-hostname".

Strangely enough, it did help.  It reminded me that 'unassigned-hostname'
isn't set by netcfg (it uses 'debian' as the default hostname).  Instead,
the preseed file you sent earlier contains the line:

d-i netcfg/get_hostname string unassigned-hostname

Which is what's causing the drama.  Remove that line (and the one after it,
preferably) and I strongly suspect all will be well.

- Matt

--- End Message ---

Reply to: