[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#506263: marked as done (Installation report - grub failed when installing from hd-media)

Your message dated Thu, 13 Jan 2011 00:26:22 +0000
with message-id <1294878382.3497.168.camel@eeepc.Belkin>
and subject line 
has caused the Debian Bug report #506263,
regarding Installation report - grub failed when installing from hd-media
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

506263: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=506263
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Boot method: USB memory stick with businesscard.iso + firmware.tar.gz
Image version: http://cdimage.debian.org/cdimage/lenny_di_rc1/i386/iso-cd/debian-testing-i386-businesscard.iso + http://ftp.nl.debian.org/debian/dists/testing/main/installer-i386/current/images/hd-media/boot.img.gz
Date: 2008.11.17

Machine: HP ProLiant something (new server)
Processor: Some kind of 4-core Xeon (or 2-core + HT?) 2.5ghz
Memory: 4096MB
 Filesystem            Size  Used Avail Use% Mounted on
 /dev/cciss/c0d0p7      32G  1.1G   29G   4% /
 /dev/cciss/c0d0p1     942M   26M  869M   3% /boot
 /dev/cciss/c0d1p1     539G  198M  539G   1% /export
 /dev/cciss/c0d0p5      63G  181M   59G   1% /home
 /dev/cciss/c0d0p8      32G  520M   30G   2% /var

(The HP SmartArray RAID controller was set up with one "RAID1+0" volume
and another "RAID6" volume)

Output of lspci -knn (or lspci -nn):
 Sorry, I don't have access to the machine at the moment

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [O]
Detect network card:    [O]
Configure network:      [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Install base system:    [O]
Clock/timezone setup:   [O]
User/password setup:    [O]
Install tasks:          [O]
Install boot loader:    [E]
Overall install:        [O]


GRUB 1.x fails to boot from hard drive after installer reboots; 
hangs after the BIOS prints "Booting from hard drive" (absolutely no
GRUB messages or anything). 

Re-inserting the USB stick with the installer and rebooting 
causes the machine to boot successfully from HD. (HD has higher boot 
priority than USB memory stick, so the contents of the USB stick is
probably irrelevant). 

It appears that the presence of an USB stick during GRUB install
confuses GRUB about its whereabouts. I believe the contents of
/boot/grub/device.map was something like this:
  /dev/sda         (hd0)
  /dev/cciss/c0d0  (hd1)
  /dev/cciss/c0d1  (hd2)

(unsure about the last two lines as this is from memory, but they
definitively listed something about /dev/cciss)

also /boot/grub/menu.lst had an entry "root  (hd1,0)"

/dev/sda is of course the USB memory stick. 

So, the first stage grub loader looks for itself on the second 
"hard drive" (hd1), which only works when there's an USB stick present
during boot to take up the (hd0) slot.

To get the machine booting without requiring the memory stick being left
in an USB port, I edited /boot/grub/device.map and removed the
"/dev/sda" entry, and corrected the /dev/cciss entries to start with
(hd0...something?) Also changed /boot/grub/menu.lst to contain "root
(hd0,0)", then ran update-grub, and finally 'grub-install (hd0)', IIRC.

Sorry for not having the exact details about everything, but as I
mentioned I don't have access to the machine at this moment.

Also, the network cards required bnx2 firmware debs on the memory stick.
It'd be helpful if the installer could include an URL to the
firmware.tar.gz and/or pointers to the appropriate section of the
installation manual for how to include those files, when it puts up the
error message about missing firmware.

--- End Message ---
--- Begin Message ---
Closing as the improvement was already commited.

Melhores cumprimentos/Best regards,

Miguel Figueiredo

--- End Message ---

Reply to: