[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#239738: marked as done (installation-reports debian-installer beta3)

Your message dated Wed, 12 Jan 2011 00:28:55 +0000
with message-id <1294792135.3497.155.camel@eeepc.Belkin>
and subject line 
has caused the Debian Bug report #239738,
regarding installation-reports debian-installer beta3
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

239738: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=239738
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports
Debian-installer-version: http://gluck.debian.org/cdimage/testing/sarge_d-i/i386/beta3/sarge-i386-netinst.iso d/l on 3/20/2004
uname -a: Too late, I was installing on a toasted machine.  I HAD been running a self built 2.4.25 kernel with testing alsa-drivers
Date: 3/20/2004 midday to 3/21/2004 evening (MST)
Method: netinst CD-ROM, no proxy, simple home network setup 
Machine: PC 
Processor: Intel Pentium 4 2.40GHz
Memory: 512MB DDR
Root Device: /dev/hda 
Root Size/partition table: See below
Output of lspci:
00:00.0 Host bridge: Intel Corp. 82865G/PE/P Processor to I/O Controller (rev 02)
00:01.0 PCI bridge: Intel Corp. 82865G/PE/P Processor to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corp. 82801EB USB (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801EB USB (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801EB USB (rev 02)
00:1d.3 USB Controller: Intel Corp. 82801EB USB (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801EB USB2 (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corp. 82801EB LPC Interface Controller (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801EB Ultra ATA Storage Controller (rev 02)
00:1f.3 SMBus: Intel Corp. 82801EB SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801EB AC'97 Audio Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown device 4150
01:00.1 Display controller: ATI Technologies Inc: Unknown device 4170
02:01.0 Multimedia video controller: Miro Computer Products AG DC20 ASIC (rev 01)
02:02.0 SCSI storage controller: Adaptec AHA-2940UW Pro / AIC-788x (rev 01)
02:05.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
02:08.0 Ethernet controller: Intel Corp.: Unknown device 1050 (rev 02)

Base System Installation Checklist:
Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Since I learned the sarge installer supported LVM I have been itching to
try it; LVM representing the feature that hooked me on SuSE some years
back.  I was planning on doing the evaluation on a 'non-production'
machine, but it turns out I toasted my main desktop and that pressed the
issue.  Note also, that I was not planning on submitting installation
report, so my pre-installation data is incomplete; once I began
encountering errors, I kept reasonably good notes.

In general, the partitioning scheme I'm looking for is:
  /dev/hda1 24.6M /boot - format ext3
  /dev/hda2 254.9M swap
  /dev/hda3 838.9M / - format ext3
  /dev/hda4 extended partition
  /dev/hda5 838.9M PV
  /dev/hda6 1.6G /usr/local - 'keep & use' (ext3)
  /dev/hda7 3.2G /home - 'keep & use' (ext3)
  /dev/hdb1 4.3G PV
  /dev/system/usr 3.2G /usr - format ext3 
  /dev/system/var 973M /var - format ext3 

My original partition settings were:
  /dev/hda1 24.6M /boot - ext3
  /dev/hda2 254.9M swap
  /dev/hda3 838.9M / - ext3
  /dev/hda4 extended partition
  /dev/hda5 838.9M /var - ext3
  /dev/hda6 1.6G /usr/local - ext3 
  /dev/hda7 3.2G /home - ext3
  /dev/hdb1 4.3G /usr - ext3

So my desired changes don't require any partition table changes per
se, just using the current partitions differently.  As it turns out,
I misread the /usr/local/man/man error below as /usr/man/man.  Because
of this I wound up re-running the installer *alot* before I realized the
obvious solution to my woes.  Most of the things I would not have
noticed if I had read 'local' correctly the first time.

Scenario Defects:
1. My first attempt failed inside of the LVM Volume Group creation
   dialog.  On this occasion I was also attempting to setup root as an
   LVM LV (on a whim, simply to see if it would work).  The virtual
   console errors suggested that pvcreate had not been run on the LVM
   PV designated volumes.  I rebooted, respecified my partition
   settings, wrote them, and before requesting an LVM VG creation,
   I went to the virtual console and ran pvcreate by hand on the
   appropriate partitions.  This seemed to solve the problem.  I have
   since attempted to RELIABLY reproduce this without success.  However,
   the error occassionally does occur, and on each occasion I've been
   able to resolve the issue by ALT-F2'ing and pvcreate'ing the
   appropriate partitions.  Sometimes I have noticed that only one of the
   partitions (/dev/hdb1) needs to be pvcreate'd (/dev/hda5 is OK),
   othertimes (after a reboot), both partitions still belong to the
   'system' volume group (from the previous boot), so I have to
   pvcreate -ff them.
2. The base-files package would fail to install:
	 Setting up base-files (3.0.13) ...
	 ln:  `/usr/local/man/man': File exists
	 dpkg:  error processing base-files (--install):
	  subprocess post-installation script returned error exit status 1
	 Errors were encountered while processing:
   This was because I was mounting my /usr/local as 'keep & use' and it
   had a pre-existing man/man.  I had to ignore my pre-existing
   /usr/local to complete an installation.  Should the base-files
   package do this?

Generic Defects:
1. In 'Method for using this partition', if you accidentally choose 'Use
   partition as a PV for LVM', you can't change to 'Keep and use the
   existing data in the partition'.  You must back out of and re-enter
   the partitioning phase.  I tried reproducing this, I could not, but
   I did notice that if you keep changing the 'Method for using'
   setting, that 'keep & use' COULD be mysteriously absent from choices.
   Sometimes it was there, sometimes not.  If the current usage is 'PV
   for LVM', 'keep & use' always seemed to appear.  Which does not seem
   to jiv with my first experience.  I was able to reproduce this with
   any IDE partition.  I could NOT reproduce this with a LVM LV, in
   which case the 'method of using' seemed flawless, always giving the
   'format', 'keep & use', or 'do not use' choices.
2. More than once, after setting up my partititions, after filesystems
   are created, I got two 'The ext2 filesystem passed a basic check.
   For a more comprehensive check, use the e2fsck program'.  Which may
   very well have been true, but it made me go back and double check my
   partitioning because I thought I had mistakenly specified ext2 vs
   ext3.  Unfortunately once you go into partitioning, all settings are
   lost (see #4) and you have to respecify them anyways to move on.
   I suspect this is from my two 'keep & use' partitions, in which case
   the message was slightly inaccurate (the partitions are ext3, not
   ext2).  Listing the mount point or partition in the message would
   provide alot of clarity.  I never *consistently* got these messages,
   though 99% of the time I had two ext3 'keep & use' partitions.
4. Setting a partition to PV for LVM, return to partition table
   overview, then change it back to 'keep & use'.  Returning to
   partition table overview does not display the detected filesystem
   type anymore.  You must exit 'Partition Disks' and reenter it again,
   which also looses all your previous partition setup.
5. I could not determine the distinction between the 'martian man' and
   the 'smiley face' icon in the partition overview.  I realize I could
   read the documentation, but more to the point:  I always configured
   the partition settings identically, and the use of these icons seemed
   random (for both IDE partitions as well as LVM PV).  Note the normal
   vs reverse video mode (how I interpretted it) was consistent.

1. From a usability standpoint, I think it would be prudent to list
   which drive & partition you are editting the install settings for
   when you are in the 'Partition Settings:' dialog.  I needed to keep
   two partitions of user data from being touched during the install (I
   live dangerously don't I), and I kept backing out of 'Partition
   Settings' just to be sure I wasn't wiping out the wrong partition. 
2. Partition settings are lost after you setup your LVM configuration.
   I would notoriously forget this so the first couple install attempts
   I kept having to restate my /boot and / partition desires after my
   LVM config.  Couple this with my comment above, and it turned into
   a longer (and more tedious) affair than it needed to be.  Perhaps
   a instructions to LVM users suggesting to
	  - FIRST do the 'size' partition,
	  - THEN the LVM configuration, and
	  - FINALLY the filesystem & mount point settings would be helpful.
   I would think users that desire LVM are the same users who would be
   happy and content if the ideal steps were simply stated, instead of
   having to glean this from experience.

Keith Hellman                             #include <disclaimer.h>
khellman@mcprogramming.com                from disclaimer import standard

"Every man knows he is a sissy compared to Johnny Cash."

-- Bono (U2)

--- End Message ---
--- Begin Message ---

Thanks for your report.
Closing as it's an installation report from debian installer version
which isn't supported anymore.
Feel free to test and report any issues against the current debian
installer release (Squeeze RC1) which supports more hardware and also
it's improved.


Melhores cumprimentos/Best regards,

Miguel Figueiredo

--- End Message ---

Reply to: