[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#307834: marked as done (Installation: Micron Transport floppy=nofifo problem)

Your message dated Tue, 11 Jan 2011 22:57:47 +0000
with message-id <1294786667.3497.25.camel@eeepc.Belkin>
and subject line 
has caused the Debian Bug report #307834,
regarding Installation: Micron Transport floppy=nofifo problem
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

307834: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=307834
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: R3 5/4/05 people.debian.org/~joeyh/d-i/images/daily/floppy/ 
uname -a: n/a
Date: 5/4/05 all day
Method: Floppy/cdrom/network

Machine: Micron Millenia Transport w/ docking station
Processor: Pentium 133
Memory: 32M
Root Device: /dev/fd0
Root Size/partition table: n/a
Output of lspci and lspci -n: n/a

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [E]
Detect hard drives:     [O]
Partition hard drives:  [ ]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]


I originally installed Woody from floppy/cdrom, and it worked ok.
I had to use the floppy=nofifo parameter for the floppy drive to work properly.

When trying Sarge, I used floppy=nofifo, but got results consistent with not using it. It booted fine from the boot disk, but when loading the root disk, I'd get:
floppy0: long rw: 24 instead of 12
rs=18 s=1
rh=1 h=0
rt=0 t=0
heads=2 eoc=0
spt=18 st=0 ss=1
FAT: bogus logical sector size 0
VFS: Can't find a valid FAT system on dev 02:00
Cannot find root floppy: /dev/floppy/0: cannot mount

The error wasn't absolutely consistent. The long rw: value varied. Usually 24, but sometimes 13 or 20. The rs= value changed too, 2 and 15 respectively. 

The install media was fine. I checked, double checked, cleaned the drive, and even created media on the same computer which was failing. On occasion (3 times out of 20 or so)

I also tried various other parameters: floppy=0,daring; =broken_dcl; =slow, and none helped.

I don't know why floppy=nofifo fixed the problem with Woody (Woody had the same symptoms without it). It appears to me as though floppy=nofifo simply doesn't work. At least it doesn't do what it did with Woody.

I've since done a dist-upgrade instead, so I'm not in need of this to work, but it would be nice to have it fixed for the next person who tries it. I'll be happy to do whatever testing that may be needed.

-Eric 'shubes'


--- End Message ---
--- Begin Message ---

Thanks for your report.
Closing as it's an installation report from Sarge and floppies which
aren't supported anymore.
Feel free to test and report any issues against the current debian
installer release (Squeeze RC1) which supports more hardware and also
it's improved.


Melhores cumprimentos/Best regards,

Miguel Figueiredo

--- End Message ---

Reply to: