[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#606242: Replicated on another machine. Wonky install screen 'CONTINUE' button icon. Debian-squeeze-di-Beta2-i386-DVD-1



I am still working on how to succesfully mount usb thumb drive to get a 'di Saved Debug Log' of a machine that fails the debian-squeeze-di-beta2-i386 install.
You can willingly have the logs when I achieve. It's just a matter of time and research.
---

A New Observation, 23.12.2010.
When the machine has a reasonable amount of install processing to do.
My scenario was another squeeze-di-beta2-i386 install on the same machine :-
 ('A bit' KT7, Raid, 1 Ghz.AMD AThlon K7, 850 Mhz,  SDRAM 1Gb.Award Modular Bios v6.00. Via KT 133 ATX, Hipoint HPT370 raid controller.)
 The first occurence of the symptom occured this time, at the Partition Manager stage.
 Screen: 'Partition Disks','Done setting up the partition' line was selected and highlighted,
 with the mouse cursor pointer arbitrarily positioned on the dot of the letter 'i' of the [Continue] screen icon.
The [Continue] icon greys out, the selected line goes to dark red.
 The new observation is, that this is the correct operation, until this specific processing completes.
 It could take a while in a good working situation, lets say 20 seconds, or longer or shorter, and then the screen flicks correctly to the next task at hand,
 depending what processing needs to be done.
 The majority of the observation is correct and 'Working as coded' and as we would like.
 The 'Fault symptom' is when this action stays frozen for half an hour, and would be longer,
 if you do not realise you have to trigger the process resumption by waggling the mouse a little bit and therefore instantaneously freeing up
 the processing  by - I guess - exiting a wait loop maybe.

---

Replication and observations of the fault symptom on a DifferenT machine, 08.01.2011.

Mouse: Optical USB Lenovo, three button and a scroll pressure thingy,
Part number: 24P0494 IBM FRU P/N 24P0495 Model: MO09BO IBM Scroll Point.
which has been working adequately for, I don't know, 6 years maybe ? on Debian OS's going back at least four Toy Story Characters.
 It is now on the end of a KVM to three machines, except when I am using this mouse without a KVM mainly for this fault replication

Machine: Motherboard: MS5169
Processor:
AMD-K6-2/400 400.9Mhz
Memory:
Memtest86+ v4.10 224MB pass:1 errors:0

Bios:
American Megatrend AMIBIOS 1996 A5169MS v2.6 121598
51-1215-000000-00111111-071595-41E_43C-MS5169-T99-H

DASD pci board: Manufacturer:
"For Best Ports Connection" (Is the manufacturers name.)
Sil 3114 sata raid bios version 5.3.14 2006.
Serial ATA host controller card SA3114-41R 4 port.
chip: Silicon Image chip StealVine Sil 3114 CTU.
printed on the chip: QG6332.1-1 0644 AD03AX2.
printed on the sata pci board: SATA3114-A01

Extra detail:-
Motherboard:
MicroStar MS5169-T99-0 www.msi.com.tw

Chipset:
Screen printed on motherboard: MS5169 Ver 3 AL9.
Book in new unopened box: Aladdin AL9, V2.1 B manual revision.
Screenprinted on Chipset Aladdin 5 M1531 / M1543.

Memory:
SDRAM PC100 DIMM, No Parity, Non ECC.

Fault Scenario :- debian-squeeze-di-beta2-i386 install.
Graphical Installer.
Screen: 'Configure the network','Do not configure the network at this time'.
[Continue] (OK) 'Please enter the host name for this system'
I left the default debian host name in the field.
[Continue] randomly choosing to place the mouse cursor on the dot of the letter 'i' in the Continue icon, which, on pressing the left mouse button greyed out the Continue icon and darkened the red line selected. Eventually after pencil writing up this report, I moved the mouse cursor minimally (let's say 1 mm) with the mouse cursor still inside the Continue icon frame, and the programme continued satisfactorily.

Note: this is all on a DifferenT machine to the original bug report, with a different a bios and chipset manufacturer, etc.

I selected the [Go Back] screen icon and replicated the fault symptom again in the same place -'Please enter hostname for this system'.- I could not replicate when I went [GoBack] then [Continue] for attempts 3,4,5. It did replicate the symptom on attempt 6 and froze in exactly the same place.

Try 7: I selected icon [Go Back], On Screen:'Debian Installer Main Menu','Configure the network',[Continue] froze, write it up, waggle, OK!

Try 8: 'Debian Installer Main Menu','Execute a shell' [Continue] Froze, write it up, waggle, OK!

Try 9: 'Execute a shell' [Continue] selected with mouse OK, 'Interactive shell' [Continue] Busy Box V1.17.1, worked OK!

Try 10: Screen: 'Partition Disks', 'Write changes to disk' [Continue] with mouse cursor pointing to the centre of the letter 'o' on Continue. (I fancied a change) pressed left button mouse, the process Froze. I penciled wrote this report up, Waggled the mouse cursor 1 milimetere, still in the icon framework, the process continued to work OK!

Try 11: With the objective to get the install debug log saved and off the machine.
At Screen: 'Install the base system','Not installing to unclean target' (On purpose) [Go Back] 'Installation step failed' (On purpose) [Continue] Screen:'Debian Installer Main Menu','Save debug logs] Worked OK!

It's now 11.01.2011. I have yet to achieve getting my usb flash thumb drive mounted to relocate the 'debian installer debug log' to another pc easily and quickly, for transmmision to here. Alas, I am researching and working on it from time to time. Work in progress !

T'is a bit of a blow, I have a tissue of a memory, but I cannot put my finger in it nosing through my notes. It'snot the only icon acting like a swine. I am sure I had a couple of occurences of the [Go Back] icon action also being blocked. The [Continue] button icon was used a lot when I flew through the normal install, so it is picked a lot in my examples. I will play around with the [Go Back] icon button to see if I can stop it running. It'snot a button I use a lot normaly running an install. I was hoping an early bird highlighting this in 'Squeeze di Beta 1+2' might relieve the symptoms and prevent it becoming pandemic later.

If I had to make a generalisation of the 'fault determination', this symptom seems to be mouse and hardware independant.
If I had to guess with the info to date, I might say the software for the icons 'Continue' and 'GoBack' and maybe other icon's used to trigger the 'Debian Graphical Installer' processes are dependant on the cursor being moved, a dependancy asssumption in the screen icon software that catches out, unwary people like me. (Ergonomics?)

I hope this session helps someone progress the fault and improves the excellent Squeeze di. Regards McTech.

Reply to: