[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#179243: marked as done (job control disabled)

Your message dated Sat, 8 Jan 2011 14:59:09 +1100
with message-id <20110108035909.GW2766@hezmatt.org>
and subject line unreproducible: job control disabled in d-i shell over serial console
has caused the Debian Bug report #179243,
regarding job control disabled
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

179243: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=179243
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: rootskel
Version: 0.16
Severity: minor

Here is a transcript:

 Debian Installer Main Menu
   5. Execute a shell
 Prompt: 1 - 5> 5<ENTER>
 Debian Installer Main Menu

 Interactive shell.
 You are running...
 [Press "enter" to continue]
 /bin/sh: can't access tty; job control turned off

Job control works if the inittab entry for debian-installer is
changed to


but this does not work on serial consoles.  Does anyone understand
serial consoles?


--- End Message ---
--- Begin Message ---
I've just tried a d-i run over a serial console using an image built from
SVN, and it seems to work fine.  I jumped back to the menu, arrowed down to
'Execute a shell', and when it started there was no mention of a lack of job
control, or (as far as I can tell) any problems with job control.

Given how old this bug report is, I'm pretty confident in saying it was
fixed a long, long time ago by some change or another, and so I'm closing it
off.  If anyone can actually reproduce a problem with job control in a d-i
shell with a current (squeeze RC or daily, or even a Lenny installer image),
please feel free to reopen this bug with a detailed description of how to
reproduce the problem.

- Matt

--- End Message ---

Reply to: