[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#600671: installation-reports: Grub2 failed to install



Hi Jonathan!

On Sat, 06 Nov 2010 19:26:12 +0100, Jonathan Hutchins wrote:
> Boot method: Unetbootin USB image
> Image version: Default testing image for Unetbootin

I did not know at all 'Unetbootin', but given that the Debian Installer
is available as a USB image as well, this latter is the preferred
method...

> On installation over Win7 grub2 failed to install and system would only boot 
> to Windows.

...which can be run even *from* Windows.

> After removing Windows and re-installing Squeeze, system would 
> only boot with installer USB attached.  Running grub-install /dev/sda fixed 
> the problem.

Anyway, please do not hijack thread, you have experienced two bugs that
have nothing to do with mine, with a minor exception for the first one
where for both of us GRUB-2 failed to install, but I guess in two
*completely different* situations (you provided are very few information
about the installation steps...).

And actually, the second bug you have experienced has already been
reported three times, now merged:

  http://bugs.debian.org/568529
  http://bugs.debian.org/579519
  http://bugs.debian.org/589823

FWIW, I tried both on QEMU and on my real IBM/Lenovo ThinkPad X60 and
GRUB-2 cleanly installed itself on the internal HD and not on the USB
stick, I will send shortly another mail to the bug above.

For this reason, I do not think it is worth to duplicate Jonathan's
first bug as new, given that it is mostly impossible to reproduce it
without further information.

On Mon, 08 Nov 2010 00:46:14 +0100, Miguel Figueiredo wrote:
> it failed with the installer:
>
> Oct 17 16:36:41 grub-installer: info: Installing grub on '/dev/sda'
> Oct 17 16:36:41 grub-installer: info: grub-install supports --no-floppy
> Oct 17 16:36:41 grub-installer: info: Running chroot /target grub-install  --
> no-floppy --force "/dev/sda"
> Oct 17 16:36:41 grub-installer: /usr/sbin/grub-probe: error: no such disk.
> Oct 17 16:36:41 grub-installer: Auto-detection of a filesystem module failed.
> Oct 17 16:36:41 grub-installer: Please specify the module with the option `--
> modules' explicitly.
> Oct 17 16:36:41 grub-installer: error: Running 'grub-install  --no-floppy --
> force "/dev/sda"' failed.
> Oct 17 16:36:53 main-menu[387]: (process:19453): File descriptor 3 (pipe:
> [2326]) leaked on lvdisplay invocation. Parent PID 19490: /bin/sh
>
> ...but worked when you run grub-install /dev/sda

Miguel, please re-read the full bug: you replied to Jonathan (and not
the original submitter, i.e. me) including an excerpt of my log, which
is obviously wrong.  In my situation manually running `grub-install
[...]` failed as well.

And please do not top post: http://en.wikipedia.org/wiki/Top_posting.

Thx, bye,
Gismo / Luca

Attachment: pgpYSMXM1D5Uo.pgp
Description: PGP signature


Reply to: