[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#550584: Running flash-kernel automatically from postinst



Joey, can you please help review this patch?

* Steve McIntyre <steve@einval.com> [2010-09-23 12:55]:
> tags 550584 +patch
> thanks
> 
> Hiya,
> 
> I'm just upgrading the kernels on the armel dev boards we're hosting
> at ARM for buildds, and I've done exactly what's suggested here. I've
> added the following script as /etc/kernel/postinst.d/zz-flash-kernel :
> 
> -----------
> #!/bin/sh
> 
> version="$1"
> bootopt=""
> 
> # passing the kernel version is required
> [ -z "${version}" ] && exit 0
> 
> echo "Running flash-kernel ${version}"
> flash-kernel ${version}
> ---------
> 
> -- 
> Steve McIntyre, Cambridge, UK.                                steve@einval.com
> Support the Campaign for Audiovisual Free Expression: http://www.eff.org/cafe/
> 
> 
> 
> 
> -- 
> To UNSUBSCRIBE, email to debian-boot-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> Archive: 20100923115546.GA24258@einval.com">http://lists.debian.org/20100923115546.GA24258@einval.com

-- 
Martin Michlmayr
http://www.cyrius.com/



Reply to: