[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#446896: marked as done (debian-installer: does not detect pci network cards)

Your message dated Fri, 10 Sep 2010 17:49:12 +0000
with message-id <E1Ou7iq-0004gg-7p@ravel.debian.org>
and subject line Closing oldbug report against debian-installer #446896
has caused the Debian Bug report #446896,
regarding debian-installer: does not detect pci network cards
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

446896: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=446896
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: debian-installer
Severity: normal

I have tried to install this week's build of lenny on a Dell 'Optiplex 
GX1' which has I believe, a custom motherboard made by Dell. This mobo 
has onboard ethernet. I also have two PCI ethernet cards which 
connect via a PCI-to-ISA bridge.

When I tried to install lenny I was unable to configure the network at 
all. This is because the installer could not install a driver for the 
onboard nic (it said 'could not detect any network card, but also 
suggested to try the driver for a National Semiconductor 8390, which 
didn't work). It also failed to detect the PCI cards.

When I tried the same thing using stable 'etch', it managed to load a 
driver for the onboard card, which it detected as a National 
Semiconductor DP83815 (MacPhyter). However the network still didn't 
work. But the installer also detected the PCI cards, which did work to 
get the network up and running. 

I think the onboard network adapter may be broken. However there seem to 
be two failures of the lenny installer here, where the etch installer 
succeeded: the failure to correctly identify the onboard card, and the 
failure to detect at all the PCI cards. Perhaps these are due to support 
for 'obsolete' hardware being removed from the installer? In any case 
perhaps someone can find out why these happened by seeing the difference 
in behaviour from etch, and maybe fix it if it's considered important. 

-- System Information:
Debian Release: 4.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18jack1
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)

--- End Message ---
--- Begin Message ---
We are closing this bug report against debian-installer 
for one of the following reasons:
- it was reported with a pre-lenny version of Debian
- indications in the bug report give the feeling that
  the reported problem was lying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: