[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#316783: marked as done (Problems attempting to install Sarge (Hard drive is at /dev/hdg))

Your message dated Wed, 08 Sep 2010 03:58:00 +0000
with message-id <E1OtBnM-0004kB-Qn@ravel.debian.org>
and subject line Closing old installation report #316783
has caused the Debian Bug report #316783,
regarding Problems attempting to install Sarge (Hard drive is at /dev/hdg)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

316783: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=316783
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Hi, Debian!

I tried installing Sarge a couple of days ago.  I had two problems: (i)
After grub, the boot loader, was installed on my hard drive, nothing
worked:  Not even grub;  (ii) The supplied kernel I installed didn't boot

First question:  Have you got this form (debian-report-template)
available in a plain text format?  Stripping out HTML tags is tedious and
unproductive.  I cannot bring myself to send HTML mail, since I don't and
can't know whether you'll be using a mail client with an HTML renderer.

Debian-installer-version: Double DVD, 3.1r0a "Sarge" June 2005
uname -a: Linux acm 2.4.17 #3 Sun Nov 9 13:51:03 CET 2003 i686 GNU/Linux
  [N.B.:  This kernel was custom built on Woody.  I've attached it's
          configuration file (i.e. the one that specifies the options to
          compile into the kernel).
          The Sarge kernel that I tried (vmlinuz-2.6.8-2-386) didn't
          boot. (See below).
Date: Friday 2005-07-01, late evening Central European Time
Method: From Sarge DVD.  I booted my PC from this DVD

Machine: Custom built on mainboard Epox EP-8K7A
Processor: AMD Athlon 1.2 GHz
Memory: 256 Mb DDRAM
Root Device: IDE: an IBM UDMA100, 60Gb, 7200 rpm (from summer 2001) on /dev/hdg
Root Size/partition table:

   Device Boot      Start         End      Blocks   Id  System
/dev/hdg1               1           4       32098+  83  Linux
/dev/hdg2   *           5           8       32130   83  Linux
/dev/hdg3               9         139     1052257+   6  FAT16
/dev/hdg4            1025        5972    39744810    5  Extended
/dev/hdg5            1025        1286     2104483+  83  Linux
/dev/hdg6            1287        2592    10490413+  83  Linux
/dev/hdg7            2593        2723     1052226   82  Linux swap / Solaris
/dev/hdg8            3116        3246     1052257+  83  Linux <=== EXISTING Debian Woody root partition
/dev/hdg9            3247        3377     1052226   83  Linux
/dev/hdg10           3378        4683    10490413+  83  Linux
/dev/hdg11           4684        5336     5245191   83  Linux
/dev/hdg12           5337        5467     1052226   83  Linux
/dev/hdg13           5468        5729     2104483+  83  Linux <=== SuSE 8.0
/dev/hdg14           5730        5972     1951866   83  Linux <=== NEW Debian Sarge

Output of lspci and lspci -n:

0000:00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-760 [IGD4-1P] System Controller (rev 13)
0000:00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-760 [IGD4-1P] AGP Bridge
0000:00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
0000:00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 16)
0000:00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 16)
0000:00:07.4 SMBus: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
0000:00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio Controller (rev 50)
0000:00:0b.0 Communication controller: Lucent Microelectronics Venus Modem (V90, 56KFlex)
0000:00:0e.0 Unknown mass storage controller: Triones Technologies, Inc. HPT366/368/370/370A/372 (rev 04)
0000:01:05.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP (rev 04)

0000:00:00.0 0600: 1022:700e (rev 13)
0000:00:01.0 0604: 1022:700f
0000:00:07.0 0601: 1106:0686 (rev 40)
0000:00:07.1 0101: 1106:0571 (rev 06)
0000:00:07.2 0c03: 1106:3038 (rev 16)
0000:00:07.3 0c03: 1106:3038 (rev 16)
0000:00:07.4 0c05: 1106:3057 (rev 40)
0000:00:07.5 0401: 1106:3058 (rev 50)
0000:00:0b.0 0780: 11c1:0480
0000:00:0e.0 0180: 1103:0004 (rev 04)
0000:01:05.0 0300: 102b:0525 (rev 04)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [ ]
Config network:         [ ]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E] The kernel failed.  The other software seems OK.
Install boot loader:    [E]
Reboot:                 [E]


<Gripe #1:>
  The installation documentation was only available in "4-colour glossy"
  HTML format.  More to to the point, it was _FRAGMENTED_ into many
  files.  That meant (a) I had to fire up X-Windows and a browser to read
  it; (b) I couldn't scroll through the documentation, at least not very
  far; (c) To search through it for "kernel", I had to use:
    grep -A3 -B3 "[Kk]ernel" *.html
  followed by cutting and pasting filenames into the browser, rather than
  simply typing "/" in the program "less".  YUCK!
  I really don't think I should have to fire up my PPP connection and
  download debian-install.txt from the Debian site, just to get usable
  (for me, that is) installation documentation.
<\Gripe #1:>

I attempted a trial installation of Sarge in a small (2 Gb) partition
/dev/hdg14.  /dev/hdg is the only hard drive in the machine.

Already installed on the PC were Debian Woody (never brought up to full
working state), and SuSE 8.0 (works, sort of, but "could be better"),
plus one or two fragmentary experiments.

The boot loader on the machine was LILO, installed from the Debian Woody
system a long time ago.

<Please note #1>
  My system's sole hard drive is at /dev/hdg on a secondary IDE
  controller.  This is because the secondary controller runs at ATA 100,
  whilst the primary controller on the mainboard doesn't. 
  This gave me problems whilst installing Woody 3 years ago.  When I
  asked for help on <debian-user@lists-debian-org> Barney Wrightson 
  directed me to use the "bf24" boot image.  This worked.  This might
  have some relevance for my current problems.  The email discussion was
  at Subject: Woody installation: can't find my /dev/hdg to install to.
     Date: Fri, 4 Oct 2002 04:00:14 +0200
     Message-Id: <3D9CF62E.20207@dsto.defence.gov.au>
<\Please note #1>

The installation appeared to be going OK, up until when I was required to
select a kernel from a list.

<Gripe #2:>
  I didn't know how to chose a kernel.  The documentation is too vague
  here.  I know I've got an Athlon chip (1.2 GHz) in my PC, but whether
  it counts as a "k6" or a "k7" I really don't know.  The documentation
  gives a recipe for extracting more info from somewhere (I can't find
  the place right now), but this seems more hassle than is warranted.
<\Gripe #2:>

I chose a kernel more or less at random, the most vanilla looking 2.6
one: vmlinuz-2.6.8-2-386.  Should this work on my hardware?

Then the boot loader:  The prompt said something like "I've detected your
other installed systems.  It's probably OK to install grub.  OK?".  I
clicked "Yes".  Big mistake!  On attempting to reboot my PC, grub
wouldn't load:  The PC repeatedly attempted to reboot, each time
crashing.  I didn't have a working backup copy of my LILO on a floppy.  :-(

<Gripe #3:>
  There doesn't seem to be a "rescue" system on the Sarge DVD.
<\Gripe #3:>

<Suggestion #1:>
  The installation program should check for the presence of an already
  installed boot loader, and should, by default, NOT overwrite it.
  Instead it should recommend reinstalling the existing boot loader with
  an extra entry for Sarge.
  It could also suggest (to idiots like me ;-) that it's a good idea
  first to make a working copy of the existing bootloader on a floppy
<\Suggestion #1:>

Eventually, I managed to get my boot loader back by booting the rescue
system on the Woody CD1.

I then added an entry for Sarge with vmlinuz-2.6.8-2-386 into my existing
lilo.conf, and tried booting into it.  It displayed a line of dots, then
the screen went blank and stayed blank, and I had to press the reset
button.  Here is my lilo.conf entry for this:

# 2005/7/3, Debian 3.1 (Sarge with "native" kernel)
  label = S:2.6.8-2-386
  append = "root=/dev/hdg14" # "video=matrox:vesa:791"
  root = /dev/hdg14
#  append = "video=matrox:vesa:791"
  vga = 0x0301
#  append = "video=matrox:vesa:791"
#  vga = 788
# vga = 0x30A
I have attached my complete lilo.conf file.

Phew!!  In summary, my problems are: (i) Which kernel should I install on
my new Sarge installation, and do I need to give it any special
parameters; (ii) Why doesn't grub work on my machine?

Thanks for reading this far, and thanks in advance for the the help
you'll be givng me.  Have a great Sunday!

Alan Mackenzie (Munich, Germany)

Attachment: config.dot
Description: .config from my custom 2.4.17 kernel

# /etc/lilo.conf - See: `lilo(8)' and `lilo.conf(5)',
# ---------------       `install-mbr(8)', `/usr/share/doc/lilo/',
#                       and `/usr/share/doc/mbr/'.

# +---------------------------------------------------------------+
# |                        !! Reminder !!                         |
# |                                                               |
# | Don't forget to run `lilo' after you make changes to this     |
# | conffile, `/boot/bootmess.txt', or install a new kernel.  The |
# | computer will most likely fail to boot if a kernel-image      |
# | post-install script or you don't remember to run `lilo'.      |
# |                                                               |
# +---------------------------------------------------------------+

# Support LBA for large hard disks.

# Overrides the default mapping between harddisk names and the BIOS'
# harddisk order. Use with caution.

# Specifies the boot device.  This is where Lilo installs its boot
# block.  It can be either a partition, or the raw device, in which
# case it installs in the MBR, and will overwrite the current MBR.

# Specifies the device that should be mounted as root. (`/')

# Enable map compaction:
# Tries to merge read requests for adjacent sectors into a single
# read request. This drastically reduces load time and keeps the
# map smaller.  Using `compact' is especially recommended when
# booting from a floppy disk.  It is disabled here by default
# because it doesn't always work.
# compact

# Installs the specified file as the new boot sector
# You have the choice between: bmp, compat, menu and text
# Look in /boot/ and in lilo.conf(5) manpage for details

# Specifies the location of the map file

# You can set a password here, and uncomment the `restricted' lines
# in the image definitions below to make it so that a password must
# be typed to boot anything but a default configuration.  If a
# command line is given, other than one specified by an `append'
# statement in `lilo.conf', the password will be required, but a
# standard default boot will not require one.
# This will, for instance, prevent anyone with access to the
# console from booting with something like `Linux init=/bin/sh',
# and thus becoming `root' without proper authorization.
# Note that if you really need this type of security, you will
# likely also want to use `install-mbr' to reconfigure the MBR
# program, as well as set up your BIOS to disallow booting from
# removable disk or CD-ROM, then put a password on getting into the
# BIOS configuration as well.  Please RTFM `install-mbr(8)'.
# password=tatercounter2000

# Specifies the number of deciseconds (0.1 seconds) LILO should
# wait before booting the first image.
# delay=20

# You can put a customized boot message up if you like.  If you use
# `prompt', and this computer may need to reboot unattended, you
# must specify a `timeout', or it will sit there forever waiting
# for a keypress.  `single-key' goes with the `alias' lines in the
# `image' configurations below.  eg: You can press `1' to boot
# `Linux', `2' to boot `LinuxOLD', if you uncomment the `alias'.
# message=/boot/bootmess.txt
#	prompt
#	single-key
#	delay=100
#	timeout=100

# Specifies the VGA text mode at boot time. (normal, extended, ask, <mode>)
# vga=ask
# vga=9

# Kernel command line options that apply to all installed images go
# here.  See: The `boot-prompt-HOWO' and `kernel-parameters.txt' in
# the Linux kernel `Documentation' directory.
# append=""

# Boot up Linux by default.

#	restricted
#	alias=1

#	restricted
#	alias=2

image=  /boot/vmlinuz-2.4.17
        root = /dev/hdg8
	append = "video=matrox:vesa:791"
        vga = 0x030A

# If you have another OS on this machine to boot, you can uncomment the
# following lines, changing the device name on the `other' line to
# where your other OS' partition is.
# other=/dev/hda4
#	label=HURD
#	restricted
#	alias=3

  label = SuSE-8.0
  root = /dev/hde13
  vga = 788
  initrd = /mnt/hdg13/boot/initrd
  append = " ide=nodma apm=off acpi=off splash=0"  # "splash=0" appended 2004/6/9

# 2005/7/1, Debian 3.1 (Sarge)
image=/boot/vmlinuz-2.4.17 # /mnt/hdg14/vmlinuz
  label = Sarge;2.4.17
  append = "root=/dev/hdg14 video=matrox:vesa:791"
  root = /dev/hdg14
#  append = "video=matrox:vesa:791"
  vga = 0x0301
#  append = "video=matrox:vesa:791"
#  vga = 788
# vga = 0x30A

# 2005/7/3, Debian 3.1 (Sarge with "native" kernel)
  label = S:2.6.8-2-386
  append = "root=/dev/hdg14" # "video=matrox:vesa:791"
  root = /dev/hdg14
#  append = "video=matrox:vesa:791"
  vga = 0x0301
#  append = "video=matrox:vesa:791"
#  vga = 788
# vga = 0x30A

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: