[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#261899: marked as done ([i386] [20040726] [netinst] success, although with some remarks)

Your message dated Wed, 08 Sep 2010 03:58:42 +0000
with message-id <E1OtBo2-00069i-9g@ravel.debian.org>
and subject line Closing old installation report #261899
has caused the Debian Bug report #261899,
regarding [i386] [20040726] [netinst] success, although with some remarks
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

261899: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=261899
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: http://cdimage.debian.org/pub/cdimage-testing/daily/i386/20040725/sarge-i386-netinst.iso
uname -a: Linux desaxe 2.6.7-1-386 #1 Thu Jul 8 05:08:04 EDT 2004 i686 GNU/Linux
Date: 2004-07-26, past 21:00 CEST
Method: `expert26 vga=0x317` install, booting from CD, network install of sarge from http://ftp.debian.org/, unproxied

Machine: IBM ThinkPad R31
Processor: Intel(R) Celeron(TM) CPU 1066MHz
Memory: 384 MB
Root Device: IDE, /dev/hda, FUJITSU MHT2060AT (a 60 GB disk)
Root Size/partition table:

Disk /dev/hda: 60.0 GB, 60011642880 bytes
16 heads, 63 sectors/track, 116280 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1       20325    10243768+   c  W95 FAT32 (LBA)
/dev/hda2          114343      116280      976752   82  Linux swap
/dev/hda3   *       20326       21294      488376   83  Linux
/dev/hda4           21295      114342    46896192   8e  Linux LVM

Filesystem            Size  Used Avail Use% Mounted on
/dev/hda3             447M  139M  285M  33% /
tmpfs                 186M     0  186M   0% /dev/shm
/dev/mapper/main-home  36G   39M   36G   1% /home
/dev/mapper/main-tmp  1,0G   33M  992M   4% /tmp
/dev/mapper/main-usr  6,0G  857M  5,2G  14% /usr
/dev/mapper/main-var  2,0G  476M  1,6G  24% /var

Output of lspci:
0000:00:00.0 Host bridge: Intel Corp. 82830 830 Chipset Host Bridge (rev 04)
0000:00:02.0 VGA compatible controller: Intel Corp. 82830 CGC [Chipset Graphics Controller] (rev 04)
0000:00:02.1 Display controller: Intel Corp. 82830 CGC [Chipset Graphics Controller]
0000:00:1d.0 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #1) (rev 02)
0000:00:1d.1 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #2) (rev 02)
0000:00:1d.2 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #3) (rev 02)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 42)
0000:00:1f.0 ISA bridge: Intel Corp. 82801CAM ISA Bridge (LPC) (rev 02)
0000:00:1f.1 IDE interface: Intel Corp. 82801CAM IDE U100 (rev 02)
0000:00:1f.3 SMBus: Intel Corp. 82801CA/CAM SMBus Controller (rev 02)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801CA/CAM AC'97 Audio Controller (rev 02)
0000:00:1f.6 Modem: Intel Corp. 82801CA/CAM AC'97 Modem Controller (rev 02)
0000:01:08.0 Ethernet controller: Intel Corp. 82801CAM (ICH3) PRO/100 VE (LOM) Ethernet Controller (rev 42)
0000:01:09.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


1. I chose Polish version, and not everything is translated yet (I used the
expert mode, though, so I don't know what part of the not-translated stuff
is seen by the usual audience).

2. Partitions. I decided to learn about LVM. I thought that if I leave /boot
on its own partition, I can have everything else on the LVM partition (as
per [1]). Unfortunately, it turned out that in d-i I can't have / on a LVM
partition, so I decided on a single / partition (/dev/hda3). I understand that
everything not going into LVM's /home, /tmp, /usr and /var goes there, right?
Including /boot?

[1] http://tldp.org/HOWTO/LVM-HOWTO/upgradetolvmroot.html

Now as I look at it, GRUB is told to mount it read-only; is this the reason
of four "Unable to unlink device" errors after each shutdown and four ReiserFS
checks at boot (each ending with something like "partition cleanly unmounted")?

Side question: on my workstation (woody dist-upgraded to sid, kernel 2.4.18)
I have /var/log/boot* files; where are the boot logs kept now (2.6 kernel)?

3. Packages. I wanted to have a minimal install, but Polish version tries to
install by default kde-i18n-pl and openoffice.org-l10n-pl; as you can imagine,
this means a lot of packages being fetched and installed due to dependencies.
Also, I think the gs package was selected by default, which ended on a lot of
X packages being required even after I "unchecked" the -pl packages. Same goes
for the libxft1 and xfonts-biznet* packages being a part of the default,
minimal install.

The "unchecking" was a different issue, in fact. If I skipped the selecting
packages step, the installer wanted to apt-get install all of the -pl and
gs/libxf1/etc. dependencies. When I decided to select packages by hand,
I could resign from the unwanted ones in aptitude, but after quitting aptitude
the installer once again called apt-get to fetch the uwanted, additional stuff.

4. Modules. I'm a frequent reader of the debian-user mailing list, but
otherwise I wouldn't know I have to add the psmouse and pcspkr lines to
/etc/modules to "have mouse" and "have beeps". I understand that some people
don't use mouse/don't want to hear the beeper, but I think that for the benefit
of majority a Debconf question should be added to ask the user whether he wants
to use the mouse/beeper or not, maybe even with defaulting to "yes".

Same goes fot APM/ACPI. I don't know a bit about them (yet), but somehow
previously my laptop "went to sleep" when I closed the cover, while now
it doesn't seem to do it, and there's neither apm or acpi in /etc/modules.

5. Sound. As with the power management, I've yet to understand how sound
works under Linux, but I thought I'll have ALSA installed (as opposed to OSS);
I've even got a Debconf question about alsa-mixer saving the setting between
reboots. Instead, after installing GNOME I have two tabs in the Volume Control
program - one with working sliders called "Analog Devices AD1881A [OSS Mixer]",
and a second, totally empty, called "Intel 82801CA-ICH3 Modem [Alsa Mixer]".
Am I right in assuming I'm still using OSS?

6. Framebuffer. This one is of a rather wishlist priority, but it would be
nice if d-i could either somehow check by itself what is the best vga mode
for the machine or ask the user. Of course, it would also be great if d-i
could understand that if I run it with "vga=0x317", then this is the desired
parameter to (give GRUB to) pass to the kernel at boot time.

I know that this looks like a long list of grieves, but in fact I love the new
d-i so much I'm really looking forward to reinstalling Debian on my workstation
(I'd like to have LVM there as well, y'see). Thank you for your great work!

-- Shot (Piotr Szotkowski)
.--- http://shot.pl/ --- http://shot.pl/hovercraft/ --- -- -
| A distributed system is one in which I cannot get something
| done because a machine I've never heard of is down.
| -- Leslie Lamport
`----- ---- --- -- -

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: